Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

parallel:/dev/lp0, Postscript, ohne Treiber resp. nur PPD.gz > keine Warteschlange!

Guten Tag
openSuSE 11.4/x86_64/Kernel 2.6.37.6-24-desktop/KDE 4.6.00
Lexmark Optra E310/PCI-Karte Exsys 32bit

in YaST > Drucker einrichten > Drucker wird erkannt > zugehöriges PPD.gz (~generisch-cups-"Treiber") ebenso. Es fehlt aber die Verbindungs-Bestimmung (keine Warteschlange vorhanden) und ich weiss nicht wie ich eine solche anlegen kann (Detect More und Verbindungsassistent probiert > nix) müsste doch als parallel "/dev/lp0" sein.

Installierte Pakete:
-OpenPrintingPPDs (4.0.0-7.1)
-OpenPrintingPPDs postscript (idem)
-manufacturer-PPDs
-yast2-printer/yast2-hardware-detection
-pciutils/pciutils-ids/pciutils-32bit/(udev/udev-config-printer)
-cups/cups-client/cups-libs/cups-libs-32bit
-gutenprint (5.2.6-5.1) > wohl für E310 überflüssig
-foomatic-filters (4.0.6-7.8.1) > gemäss www.openprinting.org nicht zwingend erforderlich

in:
usr/share/cups/model/OpenPrintingPPDs/postscript > OptraE310...ppd.gz = vorhanden
und:
usr/share/cups > leer = no driver (sollte doch richtig sein, da bei Generisch-Postscript-"Treiber" nur PPD nötig

Nicht inst. Pakete:
-OpenPrintingPPDs-hpijs (ist ja nix HP-Printer)
-system-config-printer (ist doch für gnome > mehrere Abhängigkeiten mit Pythonpakete)

Muss ich etwas via YaST im init3 modifizieren? Was mache ich falsch/was habe ich übersehen? Ich weiss nicht wie weiter, danke gleich für jederlei Hilfe/Hinweis und wünsche Euch ein gutes Neues Jahr.


Antworten zu parallel:/dev/lp0, Postscript, ohne Treiber resp. nur PPD.gz > keine Warteschlange!:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

habe vergessen, verwende "nur" die Repos:
....update/11.4 & ....distro/11.4/repo/oss

Danks

Ist denn die lp-Schnittstelle geladen:

lsmod | grep lp
PS: openSUSE 11.4 wird nicht mehr unterstützt.

Uii, bereits Antwort,  :)
als root:
>
dhcppc2:~ # lsmod | grep lp
drm_kms_helper         36694  1 nouveau
drm                   232428  4 nouveau,ttm,drm_kms_helper
dhcppc2:~ #

--------
übrigens war ich zuvor nicht genau:
/usr/share/cups/driver > leer, kein Eintrag
--------
Dank an Sauerland

in /var/log/cups > error_log
>
E [28/Dec/2012:12:22:14 +0100] Bad request line "###" from localhost!
E [28/Dec/2012:13:28:11 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [28/Dec/2012:15:04:05 +0100] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
E [28/Dec/2012:15:04:05 +0100] [CGI] CUPS-Get-Devices request failed with status 401: Verboten
E [28/Dec/2012:23:01:07 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!

mit openSUSE 10.2/10.3 lief der Drucker und wenn ich mich richtig erinnere in etwa mit:

-evtl gutenprint
-evtl HP-Treiber
-etwas HP-Foomatic recommanded
und als "generischer printer"

Muss ich vielleicht ein "downgrade" machen?

lp ist nicht geladen (war ein bug von openSUSE 11.4 glaub ich)

lade einmal lp als root:

modprobe lpund versuch es dann noch mal.

Ein Downgrade musst Du nicht machen, Du solltest Dir eher eine noch unterstützte Version von openSUSE installieren, z.B. 12.2 oder auf 11.4 evergreen umstellen.
http://en.opensuse.org/Lifetime
« Letzte Änderung: 29.12.12, 11:46:22 von Sauerland1 »

lsmod list geladene Module
/dev/lp0 ist eine Gerät!

was hat ein Gerät mit einem Modul gemein?


kannst du diese Adresse aufrufen

 http://localhost:631

@ danke, habe ich gemacht und dann wieder yast > geht nicht

ferner sah ich in /usr/share/cups/model/OpenPrintingPPDs/postscript > Lexmark-Optra_E310.Postscript.ppd.gz = vorhanden
und in
/usr/share/cups/model/OpenPrintingPPDs/gutenprint > stp-lexmark-optra_eplus.5323ppd.gz und das selbe mit Endung ...sim.ppd.gz

erneut probiert > geht nix Warteschlange

nächster Versuch:
von "www.openprintig.org/driver/Postscript" > ich lies mir ein (OptraE310 dort gelistet) PPD-file erstellen, einmal normal und einmal als "GUI.texts limited to 39 characters", beide download und weiss aber nicht wo ich diese abzulegen hätte.

weiter entdeckte ich bei "www.openprinting.org/driver/Postscript-Lexmark" > ein noarch.rpm  :) gut > openprinting-ppds-postscript-lexmark-20110703-1lsb3.2
unter HowTo: vor install "lsb" is needed > lsb-release war bereits installiert und "lsb" habe ich noch installiert. > Neustart > YaST > Drucker hinzufugen = geht nix, hmm

@ wahre Knut
ja, das kann ich, jedoch wird dort nach root-pwd gefragt, und ich habe dann immer Paranoid-Modus ein ;)
Was müsste ich dort etwa machen? [abgesehen von root-pwd angeben]
------
Yast-HW-Info: "Abteilung" PCI > OX9162 Mode 0 (parallel port)
Kernel Treiber: parport_pc
Parallel-Controller: Oxford
Treiber: aktiv > ja, modprobe > ja, modules > modprobe parport_pc
Ressourcen: IRQ, aktiviert > ja, IRQ22

YaST-HW-Info: "Abteilung" Drucker > gibt es nicht!?

Ich als Dauer-Newbie-Dilletant  :-[ danke für jede Hilfe bestens.

noch mal die lsmod Geschichte ist Un.sinn!

 http://localhost:631

erwartet dein root-password und dann kannst du von dort versuchen den Drucker zu konfigurieren!

Wo ist dein Problem?

Sorry weil so spät-habe probiert, viele Dank an wahre Knut Berlin
Mein Problem, weil nicht verstehen > super-Paranoid :)

gemacht, Drucker hinzufügen > lokaler Printer > SCSI-Drucker
Bsp. divers, vermute > lpd://Hostname/Warteschlange > modifiziert zu = lpd://dhcppc2/dev/lp0
danach noch ein paar Druckerstandardsettings (hier bereits was falsch gemacht)
SUPER ist im YaST drin :) und Status bereit
Im Yast-HW-Info: "Abteilung" Drucker > YES is drin! jedoch hier als "/dev/lp2"

Testseite drucken > Fehler :( > /usr/bin/lp: Not allowed to print
Jetzt verbleibt noch die Printerlaubnis für Paranoide zu erreichen :)
Drucker freigeben (für entfernten Zugriff)?
oder etwas bei Richtlinien-Einstellungen?

Vielen Dank und liebe Grüsse

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Den (Deinen) User zur Gruppe lp zufügen, kannste auch mit Yast machen.

Danke @ SQL-Freak
gemacht, bin Mitglied der Gruppen "users, video (und neu) lp"

Starte einfaches Dokument in LibreOffice > Druckereinstellung > Gerät > Druckersprache > und dort steht PDF (egal ob PDF noch PS-Level des Treibers) druckt [noch] nicht.

in /usr/bin besitzen jetzt die 5 ~lp Dateien = Gemeinsamen Bibliotheken die Dateirechte -rwxr-xr-x (zuvor hatte root keine Schreibrechte > jedoch scheint mir wenig relevant)

Ich glaub ich brauch mal Urlaub :)

Noch einmal:
Ist das Modul lp geladen?

lsmod | grep lp
cups neu gestartet?
rccups restart
« Letzte Änderung: 29.12.12, 16:51:36 von Sauerland1 »

 

Zitat
lsmod | grep lp
Nochmal lp ist ein Gerät und kein Modul!
lsmod  listet geladene Modul
also ist dieser Befehl Un.sinn!

« Linux neben win 7 installierenGoto befehl für bash script »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Tag
Ein Tag ist ein englischer Begriff und bedeutet so viel wie Etikett, Mal, Marke, Auszeichner und Anhänger. Generell ist Tag eine Auszeichnung eines Datenbetandes mit...

Laserdrucker
Anders als Tintenstrahldrucker arbeiten Laserdrucker nicht mit Tinte sondern mir einem sehr feinem Pulver (Toner). Dieses wird bei hoher Temperatur mit einem Laser auf da...

Nadeldrucker
Ein Nadeldrucker ist ein Computerdrucker, der beim Druckvorgang eine Reihe einzeln angesteuerter Nadeln auf ein Farbband schlägt. Ein gedrucktes Zeichen besteht jewe...