Ihre Frage:Probleme beim Installieren von Dateien übers Terminal


Ich habe mir ein Debian System zugelegt, allerdings habe ich Probleme beim Download und der Installation von Dateien/Programmen über das Terminal, ein Beispiel:

root@DonJulius:~# sudo apt-get install p7zip-full
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket p7zip-full ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »p7zip-full« existiert kein Installationskandidat.

Ich gebe den korrekten Befehl ein und irgendwas hindert mich daran 7zip (in diesem Beispiel zu Downloaden), was mache ich falsch/ Soll ich ändern/ Überprüfen? Vielen dank

Antworten zu dieser Frage:

Dieses "Ein anderes Paket ist verfügbar" aber das eigentlich nicht erscheint bei ALLEM, obwohl das eigentliche Paket verfügbar ist!

Hat dir diese Antwort geholfen?

Woher weißt du, dass das eigentliche Paket verfügbar ist? Vielleicht ein Schreibfehler?

Mach zuerst mal ein "sudo apt-get update", um die neuesten Paket-Quellen einzuladen!

Hast du auch mal andere Programme versucht zu installieren, die vielleicht funktionieren?

z.B.: "sudo apt-get install fswebcam"

Hat dir diese Antwort geholfen?

Hallo!

Installiere dir ggf. den deb.-Pakete Installer "gdebi". Rechtsklick auf das Paket und mit gdebi installieren lassen. Dann werden Abhängigkeiten mit installiert.

Des weiteren hier das entsprechende WIKI dazu, allerdings für Ubuntu: https://wiki.ubuntuusers.de/7z/

Ansonsten wende dich ans Debian-Forum. Die kennen die Eigenheiten ihrer Paketverwaltung am besten.

Die Paketquellen aktuell zu halten, wie hier vorgeschlagen ist natürlich trotzdem sinnvoll.

Gruß

Hat dir diese Antwort geholfen?

Der Paketname stimmt schon:

# apt-cache search p7zip
liblzma5 - Bibliothek für das XZ-Kompressionsformat
liblzma-dev - Bibliothek für das XZ-Kompressionsformat - Entwicklungsdateien
p7zip - 7z-Dateiarchivierung mit hohen Kompressionsraten
p7zip-full - 7z- und 7za-Dateiarchivierung mit hoher Kompressionsrate
p7zip-rar - non-free rar module for p7zip

Ich denke Nico hat hier recht, da muss wohl nur mal ein apt update ausgeführt werden.

Hat dir diese Antwort geholfen?

Ich denke Nico hat hier recht, da muss wohl nur mal ein apt update ausgeführt werden.

Danke :)


Klappt es denn jetzt?

« Ubuntu SoftwareWas für eine Linux Distro ist das? »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!