Computerhilfen.de Logo
Forum
Tipps
News

php/xml error

Hi leute,

ich bekomme von mienem Firefox immer einen LoadXML error wenn ich eine meiner seiten ansurfe. Mit IE ist es garkein problem!

wenn ich der fehlerkonsole glaubenschenken soll dann hab ich genau an dieser stelle das problem wo der ff rummeckert!
Hier der code:
http://pastebin.com/m34db9009

wenn ich einen xml validator vertraue dann liegt das problem in zeile 4 wenn ich allerdings den angeblichen fehler behebe geht garnicht mehr ... (das <? ?> wird bemängelt)

vielleicht kann mir jemand helfen!

mit freundlichen grüßen

Xaragon


Antworten zu php/xml error:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hi |

Prinzipielles Problem bei der Fehlersuche: Du bekommst von deinem Browser einen XML-Fehler geliefert, zeigst uns aber PHP-Code (der offensichtlich fehlerfrei durchläuft). Das erzeugte XML-Dokument wäre interessant. ;)

greez 8)
JoSsiF

hi, leider weiß ich net was du von mir willst =(
die sache is die das alles durchläuft aber er nur bei dem einen spziellen link rumspackt ... sorry 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
Das erzeugte XML-Dokument wäre interessant. ;)

Was ist daran unverständlich? ;)

Könnte es sein, dass du nicht so recht verstehst, was bei deinem Programm passiert? Hast du es denn selber geschrieben?

da wirste wohl recht haben ^^

ne ich hab es net selber geschrieben. es handelt sich hierbei um eine groupware namens 'egroupware' schonmal davon gehört?
ganz im spziellen handelt es von 'mydms' meinst du mit xml ausgabe das was im FF angezeigt wird oder ?

ich poste dir hier einfach mal die ganze datei rein :x vielleicht hilft das!

http://pastebin.com/m75b82124

schonmal im vorfeld danke das du mir versuchst zu helfen :)

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hab davon gehört, aber selber noch nicht eingesetzt. Ich weiß auch nicht, wozu diese erzeugte XML-Datei gebraucht wird. Aber genau die ist interessant, der PHP-Code funktioniert ja offensichtlich :)

greez 8)
JoSsiF

hmm wenn ich das ganze validiere bekomm ich diesen fehler hier:

Line 294, Column 310: cannot generate system identifier for general entity "folderid" .

…menuaction=mydms.uifolder.copyFolder&folderid=41">Ordner kopieren</a></td>



An entity reference was found in the document, but there is no reference by that name defined. Often this is caused by misspelling the reference name, unencoded ampersands, or by leaving off the trailing semicolon (;). The most common cause of this error is unencoded ampersands in URLs as described by the WDG in "Ampersands in URLs".

Entity references start with an ampersand (&) and end with a semicolon (;). If you want to use a literal ampersand in your document you must encode it as "&amp;" (even inside URLs!). Be careful to end entity references with a semicolon or your entity reference may get interpreted in connection with the following text. Also keep in mind that named entity references are case-sensitive; &Aelig; and &aelig; are different characters.

If this error appears in some markup generated by PHP's session handling code, this article has explanations and solutions to your problem.

Note that in most documents, errors related to entity references will trigger up to 5 separate messages from the Validator. Usually these will all disappear when the original problem is fixed.



leider weiß ich nicht was ich damit anzufangen habe :x

was ich nicht versteh ist ja das die ganzen andern folder funktionieren! und jede Ausgabe wird ja gleich aufgebaut... das ist das was mich noch stutzig macht! Oder habe ich einen Denkfehler?

wenn nein woran kann es denn dann liegen das er bei dem folder mit der id = 41 nen fehler macht ? DB fehler ?
 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
hmm wenn ich das ganze validiere bekomm ich diesen fehler hier:

WAS validierst du WOMIT?

« CMS Cpeicherung der InhaltePHP Formular mit Checkbox »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!