Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Suse: 11.2 Im KDE-Desktop kein Zugriff auf USB und Floppy

Gesundes Neues Jahr allerseits.

Neuerdings gibt es im KDE keine Reaktion mehr, wenn ich ein USB-Gerät anstecke oder eine Floppy einlege.

In /dev sind die Geräte vorhanden, ich kann die Floppy auch mounten und lsusb zeigt die angeschlossenen USB-Geräte auch an.

Weiss jemand Rat, wie ich meine Geräte im Dolphin wiedersehe  ???

Ach ja, usbview sagt mir, dass /proc/bus/usb/devices nicht geöffnet werden kann und dass ich das usbdevfs-Filesystem mounten soll  ???

« Letzte Änderung: 01.01.11, 12:44:06 von hugenyn »

Antworten zu Suse: 11.2 Im KDE-Desktop kein Zugriff auf USB und Floppy:

 

Zitat
none  /proc/bus/usb  usbdevfs  defaults  0  0
solch ähnlich aussehender Eintrag müsste in der fstab zufinden sein

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

... bin gerade am Ubuntu-Rechner.

Dort gibt es in fstab keinen Eintrag wie

Zitat
none  /proc/bus/usb  usbdevfs  defaults  0  0
.
Und doch funktioniert die USB-Einbindung blitzartig.

Allerdings ist die Floppy in fstab eingetragen, sonst nur HDD und CDROM.

Hat das vielleicht etwas mit den Rules zu tun  ???

Ich melde mich später nochmal von der Suse.

Ja, auf jeden Fall

lass mal udevmonitor auf'n Konsole mitlaufen um so zu sehen was und ob was passiert wenn du ein USB-Gerät ansteckst

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

@ Der wahre_Knut aus Berlin

... ich habe mal auf 'ner Suse 11.3 nachgesehen:

 

Zitat
usbfs   /proc/bus/usb   usbfs   noauto   0 0

Mal sehen, was die 11.2 mit dieser oder Deinem Eintrag in fstab macht  ???

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

... jetzt ist es so:

 

Zitat
usbfs   /proc/bus/usb   usbfs   noauto   0 0

ist in der 11.2 vorhanden, USB-Geräte in /dev vorhanden aber keine Zugriff vom Desktop möglich.

Die mtab sagt bei angeschlossenem USB-Stick
 
Zitat
udev /dev tmpfs rw ...

In 11.3, bei der es funktioniert, steht in der mtab
 
Zitat
devtmpfs   /dev   devtmpfs  rw ...
tmpfs   /dev/shm  tmpfs  rw ...
udev kommt in der mtab nicht vor.

Als Laie gefragt: Funktioniert hier etwas mit den temporären Filesystemen nicht und was muss ich ändern  ???
 

 

Zitat
Als Laie gefragt: Funktioniert hier etwas mit den temporären Filesystemen nicht und was muss ich ändern

Die Frage muss anders lauten!
Was hast du geändert das es nicht mehr funktioniert?
Update?

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

... ja, zypper up  :-\

was sagt udevmonitor

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

 

Zitat
was sagt udevmonitor

... habe ich nicht, auch nicht in YAST.

udevadm monitor hängt und schreibt keine Ausgabe.

udevmonitor sagt auch nur was wenn ein USB Gerät eingesteckt wird

Aber schau mal in den Logs was zypper so alles updatet hat

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

 

Zitat
udevmonitor sagt auch nur was wenn ein USB Gerät eingesteckt wird

Hatte ich. udevmonitor
 
Zitat
... habe ich nicht, auch nicht in YAST.

 
Zitat
schau mal in den Logs was zypper so alles updatet hat

... ich habe leider keine Ahnung davon, was ich aus den tausenden Zeilen herauslesen soll  :-\

 

Zitat
rpm -qa --last | less

hiermit findet man alle installierten Pakete mit Datum/Uhrzeit und somit läßt sich alles ganz leicht wieder rückgängig machen.

 
Zitat
Ach ja, usbview sagt mir, dass /proc/bus/usb/devices nicht geöffnet werden kann und dass ich das usbdevfs-Filesystem mounten soll

diese Meldung bekomme ich auch, und bei mir ist alles in Ordnung. Ist also nicht von Relevanz.


Frohes Neues

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

 

Zitat
rpm -qa --last | less

Danke, wieder einen Befehl gelernt  ;)

Aber wie finde ich aus den exakt 1638 Einträgen den heraus, der mir einen angesteckten USB-Stick im Dolphin und im Desktop-Geräteüberwachung wederbringt  ???

Ich kann den Stick übrigens problemlos mounten - /dev/sdc1 /media/Verzeichnis.
 

1638 ist die Gesamtzahl der Pakete. Ansonsten ist “protokolliert“ das Stichwort (siehe K.a.Berlin). Hab mal auf einer meiner Testpartitionen die 11.2 installiert, weder unter KDE4.3.5 noch unter KDE4.5.4 tritt dieser Fehler auf. Ist also kein allgemeines Problem und liegt an deiner speziellen  Konfiguration. Grundsätzlich gilt auch hier: von nix kommt auch nix. Irgendetwas hast du verändert, hat ja wohl mal funktioniert.

 

Zitat
Ich kann den Stick übrigens problemlos mounten - /dev/sdc1 /media/Verzeichnis.

schon klar, deutest du oben schon an.

Ich persönlich hab immer mehrere Desktops installiert. So kann man Fehler schön eingrenzen.

Gruß

jetzt hab ich mal eben noch den KDE Entwicklerzweig installiert, wo genau dieser Fehler auftritt.

zumindest kann man sich auf eine deutlich gesteigerte Geschwindigkeit unter KDE4.6 freuen.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

... zuerst Danke für Eure Hilfsangebote.

Ich habe den Fehler gefunden aber das konntet Ihr nicht wissen - mein KDE-Repo 4.xxx war noch .../Factory/... und diese Diskussion hatten wir hier ja schon.

Ich habe also in YAST das Repo auf .../Release/... (wie in Dr. Suses Anleitung) umgestellt, "alle in dieser Liste aktualisiern" gestartet und nach <600 MB Datentransfer + zypper up ist alles gut  ;D

Ein deutscher Ingenieur gibt eben nicht auf  ;) 


« Fehlermeldung Out of rangeWindows Vista: Wie bringe ich meine ganzen Daten von der Festplatte auf eine externe? »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Reaktionszeit
In der Elektronik versteht man unter der Reaktionszeit die Zeit, die ein Flachbildschirm benötigt, um die Farbe und die Helligkeit eines Bildpunktes zu ändern. ...

Gerätetreiber
Anderes Wort für Treiber....

HDD
Siehe auch Festplatte ...