Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Win XP: Explorer stürzt bei Anklicken von .avi ab

Hallo
Sorry, wenn ich hier gleich ne ganz blöde Frage stelle, aber ich hab seit ein paar Tagen auch einen ganz merkwürdigen Fehler auf meinem System:

Wenn ich im Explorer-Fenster ein .avi-File anklicke, bloß einmal, um es zu markieren, stürzt mir wenige Augenblicke später der Explorer ab, und zwar ohne jegliche Fehlermeldung. Er wird einfach beendet, ohne dass ich das irgendwie aufhalten könnte ... Des weiteren kann ich auch einen großen Anteil meiner avis nicht mehr über den Mediaplayer 9 abspielen, denn auch dieser stürzt dann sang- und klanglos einfach ab, ebenfalls ohne jegliche Fehlermeldung. Nun hab ich mir den VLC Mediaplayer besorgt, und dieser spielt alle Dateien ordnungsgemäß ab, an irgendeinem von allein verschwundenen Codec kann es also eigentlich nicht liegen.

Also noch mal zum besseren Verständnis, was mich so stutzig macht ist die Tatsache, dass ich ein .avi-File wirklich nur einmal anklicken muss, nicht doppelt oder so, nur einmal auf den Namen klicken, dann rödelt auf einmal der Rechner einen Augenblick auf der Festplatte rum und schwupps, bin ich wieder auf dem Desktop und der Explorer hat sich verabschiedet. So ein merkwürdiger Fehler ist mir überhaupt noch nicht untergekommen, und ich hoffe, jemand von euch kann mir vielleicht einen Tipp geben, was das sein kann ...
Zu meinem System:
Athlon XP 3000+, 512 MB
Windows XP SP1
Mediaplayer 9, aktuellste Version

Wie gesagt, für ein paar hilfreiche Tipps wäre ich sehr dankbar, da ich inzwischen mit meinem Latein echt am Ende bin ...
Danke im Voraus!



Antworten zu Win XP: Explorer stürzt bei Anklicken von .avi ab:

Ne, das kann es nicht sein, denn eMule hab ich schon seit über einem halben Jahr nicht mehr drauf ...
Sonst noch jemand ne Idee, was ich tun könnte, um das Problem vielleicht wieder in den Griff zu bekommen, abseits von einer kompletten Neuinstallation??

Ich bin langsam echt verzweifelt ...

Ich habe den Fehler auch.
Ich habe auch gar keinen Plan was ich dagegen machen kann.

Ganz einfache Lösung - hatte nämlich das selbe problem auch. Ist aufgetreten nachdem ich einen Encoder installiert habe, der DIVX in Divx für Pocket PC umwandelt. Habe einfach den DIVX Codec neu installiert, und danach ging wieder alles.! Wie gesagt, zumindest bei mir hat es funktioniert...

Mfg

Ranger

Ja, kann ich bestätigen, auch ich hatte das Problem nach der nstallation von DIV X. Folgendes: Wenn du die Datei auch nur einmal anklickst, beginnt der Explorer Thumbnails zu erstellen, also Miniaturansichten. Da aber offenbar irgendwo in dem Code ein Fehler ist (deswegen stürzt auch der Media-Player ab) frisst der Explorer sich an der Datei dumm und dämlich, bis er wegen einem Speicherüberlauf abstürzt. Da haben die Microsoft Leute sich mal wieder was tolles einfallen lassen was nur ärger bringt. Hab zum Beispiel auch das Problem, dass wenn ich einen Ordner mit vielen Video's öffne, bei dem die Miniaturansichten aktiviert sind, der Explorer mal für ne halbe stunde nur mit erstellen von Miniaturen beschäftigt ist, bis er wieder reagiert...

zum Kotzen

----------------------------------------------------
ich glaub nicht, dass Bill Gates sich heut noch nen Rechner mit Microsoft Betriebssystem kaufen würde

Ich hatte das selbe Problem, hat sich erledigt, nachdem ich den neuesten DIVX  Codec installiert habe (www.divx.de), DIvx Play Bundle 6.2. Aber muss man aufpassen, nur den Codec installieren anklicken, der will sonst allen möglichen unnützen kram installieren...

Gruß P.

Ich hatte auch dieses Problem. Ich analysierte also den Codec mit dem das File encodiert wurde. Es war Xvid-codiert. Codec runtergeladen.

http://www.chip.de/downloads/c1_downloads_13008478.html

und danach lief es. Hab auch etwas experimentiert. Mal ein File Xvid-Codiert und auf meinem 2. Rechner wo dieser nicht installiert war (da war nur DivX-Codec drauf ud die von Windows mirgelieferten) ergab sich das selbe Problem.

Muss zwar nicht das selbe Problem sein wie bei dir, aber probieren ist besser als studieren ;)

Gruss Net7

Hallo ! Hatte das gleiche Problem , brauchte den Ordner nur zu öffnen und jedesmal stürzte der Explorer ab  :'( ! Nachdem ich mich durchs Internet gelesen hatte und zig Sachen probiert hab , hab ich meinen K-Lite Mega Codec   
 Pack neu installiert und siehe da Miniaturansichten sind alle da und Ordner kann ich alle öffnen ohne das dieser dämliche Explorer sich meldet  ():-) !
Hoffe bei Euch klappt das auch !
LG Skorpion 

Ich hatte das Problem auch. In einem anderen Forum habe ich folgende Lösung gefunden. Bei mir hats funktioniert:


Die Vorschau (Preview) Option des Explorers ist eine weitere Schlüsselfunktion, die zu Problemen führen kann. Dies tritt besonders dann auf, wenn die Vorschau, die Videos öffnet, ein Bild als Symbol anbieten möchte.

Dieses Problem beseitigen wir, in dem wir über Start ->Ausführen folgende Befehlszeile eingeben und mit Enter bestätigen:

regsvr32 /u shmedia.dll


Hoffe es klappt bei euch.

Hi,
danke für eure tolle Hilfe! Ich hatte das Problem auch: bei mir lag's am DivX.

Nachdem ich gerade das DivX-Update ("Nach Updates suchen" im Startmenü) installiert habe, funktioniert wieder alles!

Hy Leute,

vielen Dank fuer die Hilfe.
Hatte auch das Problem, und nach dem ich den K-Lite Mega Codec installiert und dadurch das alte divX deinstalliert habe, läuft alles wieder einwandfrei.

Vielen dank

MfG

AcidRain

Danke nach diesem Beitrag habe ich lange gesucht :-) !!!

Tach, ich hab alles probiert, was hier im Forum steht, leider kein Erfolg. Das Problem besteht bei mir, seitdem ich den Media Player auf die Version 10 upgedated hab  ???

hatte das selbe problem.
danke dem forum bin ichs los.

regsvr32 /u shmedia.dll

hab ich gemacht und die avis starten wieder blitzschnell und mein explorer bleibt am leben.

die minituransichten gehen zwar nicht mehr aber die habe ich auch noch nie großartig genutzt.

oh man vielen dank für den codec tip, ich wär fast verrückt geworden aber jetzt läufts wieder, danke!

Nach Update auf MediaPlayer 11 gleiches Problem und ebensi durch regedit Eintrag regsvr32 /u shmedia.dll gelöst !!!
Danke

ich hatte das selbe problem.

bei mir reichte die deinstallation des XviD-Codecs bzw. von AutoGK (einem DVD-Rip-Programm) zur Lösung. Keine Regedit notwendig.

danke für eure Hilfe.

na bitte geht doch...
wie lange  ::) hab ich mich mit dem Problem schon rumgeärgert, dass der Explorer wergschmierte sobald AVI-Dateien enthalten waren.

Die Lösung war tatsächlich  ;D regsvr32 /u shmedia.dll

Vielen Dank  

Zitat: Dieses Problem beseitigen wir, in dem wir über Start ->Ausführen folgende Befehlszeile eingeben und mit Enter bestätigen:

regsvr32 /u shmedia.dll



Antwort: das hat bei mir geholfen - danke

Also der Tipp mit dem Code von Xvid war einsame Spitze!!!! Jetzt funktioniert sogar die Miniaturansicht lol

sknepper sei dank, der tip hat das problem gelöst. ;D
August 2009

Gut das ich direkt hier auf die Profis gestoßen bin!
regsvr32 /u shmedia.dll versprach zwar eine schnelle Beseitigung des Problems, allerdings hat dies auch zur Folge, das sämtliche Dateiinformationen bei MP3 und Video nicht mehr verfügbar waren und das wollen wir jah wohl nicht!  ;)

Bei mir war es so, dass ich mehrere MP4-Dateien in AVI umgewandelt hatte und eine konvertierte AVI-Datei plötzlich bei jeglichem Versuch sie zu makieren den Explorer zum Absturz brachte, wirklich aber immer nur die eine Datei!
Auch nachdem ich es über den Datei-Browser des Konvertierungsprogramms wundersamerweise geschafft hatte diese Datei problemlos anzuwählen und zu löschen, habe und die Konvertierung erneut ausgeführt, aber das Problem war noch immer vorhanden.
Dann habe ich erfolgreich erst einmal regsvr32 /u shmedia.dll ausgeführt, aber schnell bemerkt, dass dies sämtliche Media-Dateiinformatoinen unzugänglich macht und habe dies dann mit regsvr32 shmedia.dll wieder rückgängig gemacht! Da der Störenfried den MS-MPEG4 V2 Kompriemierungscodec verwendet, habe ich diesen ganz einfach durch die aktuelle Codec-Datei im Konvertierungsprogramm ersetzt und schon war das Problem behoben!  8)

Vielen Dank für die hilfreichen Lösungsansätze, ohne die hätte ich wohl ewig im Dunkeln getappt!  :)

Ist aber wirklich ein haarsträubender Bug sowas, kann einen echt zur Weißglut bringen!

ich möchte mich für die vielen Hilfsansätze bedanken,
bin was diese Details  angeht ein ziemliches Greenhorn,
habe mir aber glücklicherweise direkt den richtigen Tipp
herausgepickt... :o:o:o

Nachdem ich den Codec 3.9.5.von der freenet-Seite neu installiert hatte, funzte die alte Kiste wieder...

schön zu sehen, das es immer noch die unermüdlichen im
Windows-Lager gibt, die mit Rat und Tat zur Seite stehen...

Danke, Danke, Danke...

Bei mir war die Lösung
=> regsvr32 /u shmedia.dll
Danke!

Gruss harry


« Windows 7: Zugriff auf Programme verweigert (Administratorenrechte)Windows 7: Windows 7: ornder löschen auf SDHC Karte am Card Rader unter Win 7 64 bit prof geht nicht »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Betriebssystem
Das Betriebssystem ist das Steuerungsprogramm des Computers, das als eines der ersten Programme beim Hochfahren des Rechners geladen wird. Arbeitsspeicher, Festplatten, E...

Binärsystem
Unter dem Begriff Binärsystem versteht man einen aus einem Zeichenvorrat von zwei Zeichen aufgebauten Code. Computer verwenden intern dieses System, das auf Basis de...

Bus System
Ein Bus ist ein System zur Datenübertragung. Durch einen Bus können mehrere Teilnehmer über eine Leitung miteinander verbunden werden, ohne dabei an der Da...