Computerhilfen.de Logo
Forum
Tipps
News

Suse: SuSE11.2 Kopfhörerausgang aktivieren

Hallo,

wie aktiviere ich am Dell Notebook die Kopfhörerausgänge? (zwei Stück)

In Kmix ist der Kopfhörer aktiv.
Sobald ich den Kopfhörer einstecke, ist der Ton an den internen Boxen weg, ist ja normal aber die Kopfhörbuchsen sind nicht aktiv. 

R700 Audio Device [Radeon HD 4000 Series]
82801I (ICH9 Family) HD Audio Controller

HDMI und Firewire gehen auch nicht.
In Kadenlive wird Firewire ist nicht verbunden angezeigt.

Müssen denn bei SuSE11.2 alle Stecker am Dell Notebook einzeln Aktiviert werden?

Gruß
Hans  

« Letzte Änderung: 23.03.10, 18:34:01 von Hans55 »

Antworten zu Suse: SuSE11.2 Kopfhörerausgang aktivieren:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

nach Anleitung von dieser Seite

http://de.opensuse.org/USB-Kopfhörer

USB Audio, Generic

kommt folgende Fehlermeldung

Fehler während der Installation von
USB Audio
Das Kernelmodul snd-usb-audio für die Soundunterstützung konnte nicht geladen werden. einmöglicher Grund dafür können falsche Modulparameter sein, sowie ungültige IO-oder IRQ-Parameter.

Damit sind wir wider bei meinem Thema,
was muss denn jetzt eingestellt werden?

snd ist installiert.

Gruß
Hans 

« Letzte Änderung: 30.03.10, 12:39:02 von Hans55 »

Installier mal Pulseaudio, dann funktioniert es evtl.
Ich habe bei meinem Dell nur ruaschen am Mikro gehabt z.B. nach der Installation von von Pulseaudio funktionierte das Mikro fast perfekt (minimales rauschen nur noch)
Wenn Pulseaudio installiert ist, dann mal unter Systemeinstellungen>Multimedia nachschauen, ob Pulseaudio oben steht, ansonsten nach oben verschieben. Evtl ein Neustart und dann mal austesten.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

Konflikt mit pattern-opensuse-kde4_pure-11.2-20.22.1x86_64

Pulseaudio kann nicht installiert werden.

HDMI und Firewire gehen auch noch nicht.

Gruß
Hans 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

Gnomes Pulseaudio und Phonon von KDE4 vertragen sich nicht.
Zur Konfiguration der HDA-Intel Soundchips hab' ich hier schon so viel geschrieben, drum bitte mal die Forensuchen bemühen.


HDMI ist einfach zu Konfigurieren und zwar per xrandr.
http://en.opensuse.org/Multiple_Displays_Using_XRandR

Ab KDE 4.4.1.x funktioniert auch die Klickvariante per Systemeinstellungen->Anzeige . Die Funktion ist auch schon in KDE 4.3.x drin, mag da aber noch noch nicht wie sie soll.

Firewire:

Sicherstellen das die Pakete mit 1394 im Namen installiert sind. Dann mit einem Editor seiner Wahl ( und Rootrechten ) eine neue udev-Regel in /etc/udev/rules.d anlegen mit folgendem Inhalt:

# Firewire
KERNEL=="raw1394", GROUP="video"
und mit dem Dateinamen 50-raw1394.rules abspeichern.

Nun noch per yast-> Benutzer und Sicherheit den Benutzer bearbeiten welcher Firewire nutzen darf. Unter Details in der rechten Spalte zusätzlich die Gruppe video ankreuzen, die Änderung übernehmen und nach erneuter Anmeldung sollte alles gut sein. Klappt es jedoch nicht, hat man evtl. ein brandaktuelles Firewireinterface, welches als Modul firewire-ohci erwartet. Die Suse ist zwar schon kerneltechnisch drauf vorbereitet, jedoch fehlt noch die Konfigurationsdatei dazu im Verzeichnis /etc/modprobe.d

Hier einfach eine Datei namens 50-ieee1394.conf mit nachfolgendem Inhalt erstellen ( mit Rootrechten ):

# IEEE1394 Firwire
alias char-major-171-0 raw1394
alias char-major-171-1 ohci1394
options ohci1394 phys_dma=1
alias char-major-171-2 video1394

Nicht vergessen zu prüfen ob in der Datei /etc/modprobe.d/50-blacklist.conf das Modul firewire-ohci als Blacklisteintrag drin steht, damit es nicht geladen werden kann. Indem Fall die Zeile mit dem Kommentarzeichen # auskommentieren und den Rechner danach neu starten.

Have Fun
« Letzte Änderung: 30.03.10, 22:45:00 von Dr. SuSE »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
Hallo,

Gnomes Pulseaudio und Phonon von KDE4 vertragen sich nicht.
Zur Konfiguration der HDA-Intel Soundchips hab' ich hier schon so viel geschrieben, drum bitte mal die Forensuchen bemühen.
...
Sry, aber da hab ich ganz andere Erfahrung gemacht, gerade mit pulseaudio funktionierte meine Soundkarte unter KDE 4.4.1 so wie sie es sollte. Auch ich hatte etliche Anleitungen zu hda intel Konfigurationen durchgelesen und versucht nach Anleitung vor zu gehen, was aber scheinbar bei mir nicht so recht wollte. Vllt. lags an mir oder den falschen Anleitungen unter opensuse.org.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

Bei mir ist noch Version 4.3.1 (KDE 4.3.1) "release 6"
installiert.
Mit 4.4.1 läuft meine SuSE hackelig
Mit Backup zurück gesetzt.

pulseaudio lässt sich nicht installieren.
 
Die Eingebauten Boxen gehen, nur die 2 Kopfhörerausgänge geben keinen Ton aus.

Gruß
Hans

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

wenn Pulseaudio für dich funktioniert ist's ja okay. Nur konkurriert pulseaudio mit Phonon aus KDE 4 und bringt keinerlei zusätzliche Features. Im Gegenteil, Pulseaudio kann ein gut funktionierendes Phonon-Setup völlig zunichte machen. drum:

http://en.opensuse.org/Disabling_PulseAudio_HowTo

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

IEEE1394 Firwire geht jetzt.

Für die Kopfhörerausgänge ( sind mir sehr wichtig) habe ich nichts gefunden.

HDMI    Modes      "1600x900" muss noch

Gruß
Hans

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Hans,

In die Rootkonsole head -n 1 /proc/asound/card0/codec*[/b] tippen. Wie lautet das Ergebnis ??

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Dr. SuSE

linux:~ # head -n 1 /proc/asound/card0/codec*
Codec: IDT 92HD73C1X5
linux:~ #


Gruß
Hans

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

bring der Suse mal den richtigen Audiokanal bei. Dein Dell hat nämlich zwei, Standard und HDMI. Dazu öffnest du einen Editor mit Rootrechten und öffnedt die Datei/etc/modprobe.d/sound
In die Mitte der Optionszeile fügst du das Soundkartenmodell hinzu

model=dell-m6

sollte danach so aussehen:

options snd-hda-intel model=dell-m6 enable=1 index=0

Speichern und nach einem Neustart sollte es wie gewünscht funktionieren. Achte darauf model englisch zu schreiben, also nur mit einem l und nicht mit zwei ll wie im deutschen.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

so sah die Datei vorher aus.

options snd slots=snd-hda-intel,snd-hda-intel
# u1Nb.Nz15uUWYSoD:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
# NXNs.pwzlOPh9eO9:R700 Audio Device [Radeon HD 4000 Series]
alias snd-card-1 snd-hda-intel


mit dem dazwischen einfügen auf verschiedenen Positionen ging nicht,
Mit deinen Muster danach ging es dann.
So ist es jetzt.


options snd-hda-intel model=dell-m6 enable=1 index=0
# u1Nb.Nz15uUWYSoD:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
# NXNs.pwzlOPh9eO9:R700 Audio Device [Radeon HD 4000 Series]
alias snd-card-1 snd-hda-intel


Es Werden auch im KMix beide Kopfhörerausgänge angezeigt und einzeln einstellbar. ;D

Super Dank Dr. SuSE.

Jetzt muss nur noch HDMI funktionieren.
Mit xrandr muss ich mich noch befassen,
der Ling ist leider in englisch.

Gruß
Hans

 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Hans,

wir werden das Kind schon schaukeln. Wenn es jetzt nur noch am Englischen hapert,ist die Lösung ganz einfach. Installiere dir die Erweiterung Foxlingo im Firefox. Danach rufst du die Xrandr Seite auf und klickst auf den neuen Button Autotrans. Schon erscheint der Text in deutsch, zwar nicht perfekt übersetzt aber durchaus gut lesbar.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

die Erweiterung Foxlingo im Firefox ist ja eine Tolle Sache.
Mit sax2 habe ich den "Klon"-Modus für den 2. Monitor
konfiguriert.
Noch bleibt mein Sony 40" TV HDMI 1366x768 dunkel.
An das Kommandozeilen-Tool xrandr traue ich mich nicht ran, ich habe angst, mir das System zu versauen.

Gruß
Hans

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Hans,

keine Angst, mit xrandr kannst du nichts falsch machen, entweder es funktioniert oder auch nicht. Es werden keine Konfigurationsdateien verändert. Xrandr ist ein reines Konsolentool, welches nur temporär die Funktion aktiviert.
Im HowTo wird immer LVDS erwähnt. Dies musst du durch HDMI ersetzen. Wie die Anschlüsse bei dir genau lauten z.B. HDMI1, VGA0 verrät dir xrandr wenn du den Befehl ohne Zusatzparameter in der Konsole aufrufst.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

die Ausgabe von Xrandr

ans@linux:~> xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 3840 x 1200
VGA_1 disconnected (normal left inverted right x axis y axis)
PANEL connected 1600x900+0+0 (normal left inverted right x axis y axis) 423mm x 238mm
   1600x900       60.3*+
   1920x1200Scaled   60.4
   1920x1080Scaled   60.5
   1600x1200      60.0
   1600x1200Scaled   60.4
   1680x1050Scaled   60.3
   1400x1050      60.0
   1400x1050Scaled   60.3
   1440x960Scaled   60.4
   1280x1024      60.0
   1280x1024Scaled   60.5
   1280x960       60.0
   1280x960Scaled   60.4
   1280x854Scaled   60.4
   1280x720Scaled   60.4
   1152x768Scaled   60.3
   1024x768       60.0
   1024x768Scaled   60.4
   800x600        60.3     56.2
   800x600Scaled   60.3
   768x576Scaled   60.4
   854x480Scaled   59.8
   720x480Scaled   59.8
   640x480        59.9
   640x480Scaled   60.1
DVI-D_1 disconnected (normal left inverted right x axis y axis)
hans@linux:~>

Da ist die Auflösung von 1366x768 nicht bei

Gruß
Hans
 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Hans,

was kann denn dein externer Bildschirm für eine Auflösung ?

Die erste Zeile Screen0 gibt dir die maximale Auflösung aller angeschlossenen Bldschirme an (maximum 3840x1200) . Die 1200 Pixel ist die maximale Auflösung in der Höhe. Meist ist aber nicht mehr drin als der eingebaute Bildschirm hergibt, in deinem Fall 900 Pixel. In der Breite bist du flexibel. Hier werden die Auflösungen einfach addiert. Dein eingebauter Bildschirm (PANEL) wird gerade mit 1600 Pixel betrieben (current 1600x900 in der Screenzeile). Bleibt nach Adam Riese 3840-1600 =  2240 Pixel für den/die anderen Bildschirme übrig. Sofern der Zusatzschirm die Aulösung von 2240 Pixel darstellen könnte , wäre der Maximalwert 2240x900 Pixel. Den Maximalwert musst da aber nicht ausschöpfen.

Mal ein Beispiel:

Eingebauter Notebookbildschirm PANEL und Zusatzbildschirm angeschlossen an DVI-D_1

xrandr --auto --output DVI-D_1 --mode 1600x900 --left-of PANEL
Das erzeugt zwei von einander unabhängige Bildschirmausgaben mit der Auflösung 1600x900. Der externe Schirm ist links vom Eingebauten positioniert ( --left-of , würde er rechts davon stehen  --right-of ) Per Maus kannst du die Programmfenster beliebig  zwischen den zwei Bildschirmen hin und herbewegen. Damit das aber auch so klappt musst Du KDE noch überreden und zwar in

Systemeinstellungen->Fenstereigenschaften->Fenstereigenschaften-Verschieben [X] Verscheibung und Größenänderungen von maximierten Fenstern zulassen.

Wo wir gerade beim Anpassen sind, auch kaffeine benötigt noch ein Häkchen weniger um das Fernsehprogramm auf den externen Schirm verschieben zu können. Dazu Kaffeine starten

->Einstellungen-Kaffeine einrichten-Verhalten. Hier Haken raus im Menüpunkt Video bei minimiertem Fenster anhalten.

Doch zurück zu Xrandr. Um bei obigem Beispiel zu bleiben, hängt der externe Schirm an VGA_1 musst du DVI-D_1 gegen VGA_1 ersetzen. Einen HDMI Anschluss kann ich in deiner xrandr - Ausgabe nicht entdecken. Mit den Auslösungen kannst du spielen bis du was siehst. Bleiben alle Bildschirme mal beim experimentieren schwarz nicht tragisch

STRG+ALT+Shift+Bildrauf

lässt das System neu starten.

Ab Xorg-Version 7.5 und KDE 4.4.x geht automatisch ein Meldefenster auf, sobald du ein Zusatzdisplay anschliesst. Da steht dann zu lesen:
Ein neuer Monitor wurde angeschlossen.
Möchten Sie das Einrichtungswerkzeug starten um das Monitor-Setup anzupassen ?

Einrichten    Ignorieren
Klickst du auf Einrichten geht's auch grafisch. Ob ich dich ggf. auf Xorg 7.5 loslasse ( das beseitigt u.a. die von dir bemängelten Ruckler in KDE 4.4.x ), hängt davon ab ob Du den bordeigenen Xorg-Treiber benutzt oder einen Propropritären.   

Aber spiel erst mal mit xrandr rum .  ;)
Auch das lässt sich automatisieren, sobald die richtigen Einstellungen herausgefunden wurden.

Have Fun
« Letzte Änderung: 01.04.10, 18:35:05 von Dr. SuSE »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

warum da DVI-D_1 steht, weiß ich auch nicht.
Am Notebook ist eine HDMI Buchse, und am TV auch.
Ich benötige das im Augenblick nicht, aber wenn das Notebook mal als Abspieler zum TV dienen soll, möchte ich einfach den Stecker rein und abspielen können, Wie ein DVDplayer.
Dann fehlt mir wahrscheinlich die Zeit zum Einrichten.

Vor dem Urlaub am 12 April will ich jetzt auch mein System sauber halten.

Frohe Ostern

Gruß
Hans
 


« Windows XP: Knoppix : Bus ErrorRed Hat: Suche RedHat 64bit Version zum runterladen »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!