Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Div. Distros: Bild-/Grafikfehler beim Booten

Hallo liebe Community,
ich habe mich wegen folgendem Problem hier neu angemeldet und hoffe auf Unterstützung, da ich gar nicht mehr weiter weiß...
Ich war auch einfach mal so frei und habe meinen alten Text aus einem anderen Forum kopiert.  ;D

...ich habe folgendes Problem und hoffe es weiß einer Rat:
Vor einer Weile bekam ich Grafikfehler auf meinem PC (WinXP x64, 512MB RAM, 256MB GeForce, >2GHz AMD Athlon 64). Die fingen schon beim Bootsplash an in Form von vertikalen Streifen, fast dieselben Streifen im BIOS. Beim Hochfahren entstand ein unbeschreiblich gestörtes Bild, auch unter Test mit Knoppix 6.7(Update: auch mittlerweile mit 6.7.1). Neue GraKa bestellt, eingesetzt und Bild war zumindest wieder OK. Reboot, weil ich XP neu installieren wollte (mit WinSetupfromUSB 0.1.1). Ging bisher an verschiedenen Rechnern problemlos, diesmal beim 2ten Mal Booten nach Grub-Loader Fehlermeldung, immer fehlte eine Datei oder war defekt. Mehrmals neu probiert, immer dasselbe. Dann Schnauze voll gehabt und Ubuntu besorgt. Nach dem Ubuntu-Splashscreen entsteht immer folgendes Bild (Update: Gilt auch für aktuelles debian mit KDE, somit kommen wir auf KDE, GNOME und LXDE):


Das Bild ist zwar von Knoppix aufgenommen worden, sie sind sich aber ähnlich. Soll heißen, dass über Knoppix auch nichts Vernünftiges herauskommt, sondern auch so ein Bild. Was aber seltsam ist, ist die Tatsache, dass bei Knoppix (Update: und nur bei Knoppix) der Cursor angezeigt wird:


Das GraKa-BIOS startet ganz normal am Anfang des Bootvorgangs und als ich sie eingesetzt habe, habe ich nur die Platine angefasst und keine sensiblen Teile.
Woran kann das jetzt liegen? Nicht schon wieder die GraKa, oder?
In die Tonne klopfen kommt leider nicht infrage...
Ich hoffe es weiß einer Rat oder kann mir bei der Fehlersuche helfen.  ???

Spätere Erkenntnisse waren dann:
"ich habe mittlerweile nach vielem rumprobieren im bios eine ordentliche darstellung gehabt, aber knoppix fror immer innerhalb kürzester zeit ein und war nicht mehr zu benutzen... ich hatte sogar schon browser + google offen.
kurz danach fror es wieder ein. an leistung konnte es kaum liegen, da ich ein eingefrorenes bild einmal bereits 2-3 sekunden nach desktop-erscheinen hatte. (...)
ubuntu 11.10 hängt im live modus entweder im titelbild fest (lange gewartet) oder bei installation bei der update/drittanbieter (nach sprachauswahl) fest, also schon vor der partitionsauswahl...
aktuell gibt es den obigen grafikfehler wieder, allerdings ab und zu nur noch in schwarz und weiß.
im bios kam es mir so vor, als habe ich es über die vga aperture size und dem faktor (8x, 4x, AUTO) hinbekommen, gerade nochmal probiert, aber nicht wieder hinbekommen.
welche einstellungen sollte ich suchen oder dringendst beachten, falls ich in die richtung nochmal suchen sollte?
(aperture size war soweit ich weiß, wie viel vom ram für grafik abgezeigt wird, aber outdated laut internet...)"

achja und graka ist ne geforce fx 5500 mit agp (8x support) anschluss. alt, aber ging nicht anders, da kein pci/-e.
mainboard weiß ich jetzt aus dem kopf nicht. war damals ein fertig-desktop-pc von hp.

Alter Beitrag - Ende

Dann ging es weiter mit einem irgendwann reparierten XP um die Daten zu sichern. Und XP lief absolut ohne Macken! Mit Ausnahme derer, die vorher schon vorhanden waren und zu diesem Diagnose-Marathon führten. Aber Grafik war perfekt. Die Daten sind aber schonmal runter und ich kann es platt machen wie ich möchte.
Aber oben genannte Distros und Umgebungen gehen immer noch nicht.

Und noch ein Update zur letzten Versuchsreihe:
Getestet mit Puppy Linux (Lucid Puppy 5.2.8 ), und jetzt kommt die Härte.
Das läuft! Und zwar runder als man vermuten könnte. Sofort standardmäßig Bild in 1680x1050 geladen und weder Artefakte noch sonstige ungewollten Effekte!

Ich hab sie Suche auch schon bemüht und hab mich mit den Ansätzen dort auseinander gesetzt, allerdings ohne Erfolg... :(

Achja, Linux-mäßig bin ich noch krabbelnd unterwegs, laufen lerne ich gerade.^^

« Letzte Änderung: 18.11.11, 18:07:18 von vvinux »

Antworten zu Div. Distros: Bild-/Grafikfehler beim Booten:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo

Noch eine kleine Frage:

Welches Modul benutzt du, für deine geforce???

Bitte poste mal folgende Konsolenbefehle:

 

lspci -nn | grep VGA
lsmod

gruss

Hardy1979

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

hey hardy,
das werde ich morgen probieren unter lucid puppy live, ist gerade etwas unvorhergesehenes dazwischen gekommen...
grundsätzlich habe ich erstmal alles standardmäßig belassen.
puppy müsste ja theoretisch ein passendes gewählt haben oder kompatibel sein.
knoppix, welches bisher am weitesten kam (bis zu einem freeze), würde mich wahrscheinlich nicht lange genug lassen, dass ich ins terminal komme. ubuntu und debian frieren leider schon beim os-splashscreen ein.  :(
allerdings kann ich den cursor bei knoppix auf dem kaputten bild bewegen und seine optik bleibt vollständig erhalten. strg+alt+f2 funktioniert dann aber leider nicht  :-\

Im BIOS mal alles auf "default" stellen!

dann wenn du booten willst hinter Boot diese Optionen eingeben

 acpi=off vga=normal
oder
 acpi=off vga=vesa

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

danke ersteinmal für eure antworten und tipps :)
also hier sind die ausgaben aus der konsole mit den befehlen von hardy:

sh-4.1# lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5500] [10de:0326] (rev a1)
und
sh-4.1# lsmod
Module                  Size  Used by
snd_via82xx            14558  0
k8temp                  2315  0
hwmon                    957  1 k8temp
pcspkr                  1179  0
snd_ac97_codec         75789  1 snd_via82xx
ac97_bus                 686  1 snd_ac97_codec
serio_raw               2928  0
snd_cs4236             19799  0
snd_wavefront          23070  0
snd_opl3_lib            5758  2 snd_cs4236,snd_wavefront
snd_hwdep               3830  2 snd_wavefront,snd_opl3_lib
snd_wss_lib            15773  2 snd_cs4236,snd_wavefront
snd_pcm_oss            26845  0
snd_mixer_oss           9963  1 snd_pcm_oss
snd_pcm                45385  5 snd_via82xx,snd_ac97_codec,snd_cs4236,snd_wss_lib,snd_pcm_oss
snd_page_alloc          4645  3 snd_via82xx,snd_wss_lib,snd_pcm
amd64_agp               5759  1
i2c_viapro              4175  0
snd_mpu401              2808  0
snd_mpu401_uart         3899  4 snd_via82xx,snd_cs4236,snd_wavefront,snd_mpu401
shpchp                 21148  0
agpgart                18904  1 amd64_agp
i2c_core               11497  1 i2c_viapro
via_rhine              14274  0
mii                     2650  1 via_rhine
pci_hotplug            18286  1 shpchp
snd_seq_dummy            907  0
fbcon                  27736  0
bitblit                 3514  1 fbcon
softcursor               805  1 bitblit
tileblit                1509  1 fbcon
font                    6916  1 fbcon
snd_seq_oss            18888  0
snd_seq_midi            3156  0
snd_seq_midi_event      3592  2 snd_seq_oss,snd_seq_midi
snd_rawmidi            11924  3 snd_wavefront,snd_mpu401_uart,snd_seq_midi
snd_seq                32379  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_seq_device          3601  6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_timer              11986  4 snd_opl3_lib,snd_wss_lib,snd_pcm,snd_seq
ohci1394               20716  0
sg                     19093  0
snd                    30859  17 snd_via82xx,snd_ac97_codec,snd_cs4236,snd_wavefront,snd_opl3_lib,snd_hwdep,snd_wss_lib,snd_pcm_oss,
snd_mixer_oss,snd_pcm,snd_mpu401,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_seq_device,snd_timer
ieee1394               50116  1 ohci1394
soundcore               3403  1 snd
fan                     2478  0
ns558                   1539  0
gameport                5717  3 snd_via82xx,ns558
thermal                 9263  0
ppdev                   4090  0
evdev                   5517  0
parport_pc             19055  0
parport                20387  2 ppdev,parport_pc
button                  3522  0
processor              24987  0
fuse                   42549  0
aufs                  110466  1
nls_iso8859_1           2937  1
nls_cp437               4465  1
usbhid                 18009  0
usb_storage            29717  1
squashfs               15984  1
uhci_hcd               15444  0
ehci_hcd               25830  0
usbcore                91279  5 usbhid,usb_storage,uhci_hcd,ehci_hcd
floppy                 40152  0
dazu dann in meinem bios, jeweils mit "optimized default" und "fail-safe defaults", die tipps von knut beherzigt und den boot manipuliert... ...und es ging! aber:
einmal zwischendurch freezete es nach einem moment, von mehreren versuchen. in der regel funktionierte es. es funktionierte auch allein mit acpi=off bzw. mit der auswahl vom lubuntu boot-menü, wenn man f6 drückt und noacpi auswählt.
was hab ich davon zu erwarten? kann ich es installieren und es läuft?
außerdem stand bei lubuntu in den bildschirmeinstellungen was von standardmonitor. und es war (logischerweise) einer 4:3 auflösung (1280x1024). ich möchte aber den monitor komplett benutzen, also in 16:9.
als system wollte ich entweder irgendeine ubuntu distro nehmen, vermutlich kubuntu oder debian mit kde.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo

mit welcher Distri hast du diesen Test gemacht???

versuche es mal mit dem nouveau Modul,

hier noch ein kleiner Artikel (Ubuntu), falls du eine andere Distri benutzt, kann es sein, dass das Paket anders heisst.

http://wiki.ubuntuusers.de/Grafikkarten/Nvidia/nouveau

http://wiki.ubuntuusers.de/Grafikkarten/Nvidia

gruss

Hardy1979

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

hallo hardy,
also die befehle habe ich per lucid puppy eingegeben.
die gegenprobe, mit der es ohne acpi startete, war mir lubuntu 11.10. allerdings weiß ich gerade nicht mehr, ob ich im terminal bei lubuntu die befehle auch nochmal eingegeben habe... muss ich nochmal nachsehen.
die artikel werde ich mir jetzt durchlesen, an den pc komme ich erst gleich. danke für die links :)


« Andere: Server- und Backupkonzept für kleines OfficeLinux / Unix: hilfe zu grep »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Hypertext
Hypertext ( zu Deutsch: Übertext) ein ein von dem Informatiker Theodore L. Nelson in den sechziger Jahren geprägter Begriff für Text, der dreidimensional g...

Textur
Unter einer Textur versteht man eine Oberflächenstrukur, die ein bestimmtes Material simuliert, wie Holz, Tapete oder Metall. Bei der 3D-Computeranimation bezeichnet...

D-RAM
Die Abkürzung steht für D-RAM. Dies ist der Dynamic Random Access Memory - der dynamische Arbeitsspeicher oder dynamisches RAM. RAM gehört zum Hauptspeiche...