Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

MySQL

Hallo zusammen

Ich habe jetzt schon lange nicht mehr mit PHP und MySQL programmiert, deshalb habe ich es wieder mal in Angriff genommen  ;)
Leider traten schon beim 1. Script Probleme auf...

<?php
$vorname $_POST["vorname"];
$nachname $_POST["nachname"];
$email$_POST["email"];
$nachricht $_POST["nachricht"];


$verbindung = @mysql_connect("localhost"
"phost75142","*Kennwort*");

mysql_select_db("phost75142")
or die (
"Die Datenbank existiert nicht.");
$eintrag "INSERT INTO contact
(vorname, nachname, email, nachricht)

VALUES
(&#39;
$vorname&#39;, &#39;$nachname&#39;,
  &#39;
$email&#39;, &#39;$nachricht&#39;)";

$eintragen mysql_query($eintrag);
if(
$eintragen == true)
   {
   echo "Eintrag war erfolgreich";
   }
else
   {
   echo "Fehler beim Speichern";
   }

mysql_close($verbindung); 

?>

Leider wird dann die Page nicht mehr richtig ausgegeben und es wird auch nichts in die Tabelle contact geschrieben... *verzweifel*

Sieht jemand den Fehler?

Thanks
Fabian Weber 

Antworten zu MySQL:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hi |

Wie immer: "Es treten Probleme auf" ist fast selbstverständlich, denn sonst würdest du nicht fragen. Also: genaue Problembeschreibung samt Fehlermeldung ist hier gefragt!

BTW: Sieht nach Pytal aus, was du da ansprichst. Glaub die haben grad DB-Probleme.

greez 8)
JoSsiF

Ja ist möglich, die haben grad alles umgestellt... ich versuche es mal auf funpic o.ä. ... Fehlermeldung gibt es eben keine... das ist schon ein bisschen komisch xD

Thanks
Fabian Weber

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Sollte ein Fehler beim Connect zur DB auftreten, dann ist klar, warum keine Meldung kommt...

Danke! Das ganze läuft jetzt auf funpic und es funktioniert so wie es sollte.

Jetzt gibt es aber eine kleine Unschönheit und zwar werden Sonderzeichen wie ä,ö oder ü nicht richtig ausgegeben, ebenfalls werden im Kontaktformular die Textfelder nicht umrandet. (->http://www.fabian-weber.ch.vu<-)

Weiss jemand an was das liegen könnte? liegt das Problem evtl. an der css Datei?

Thanks
Fabian Weber

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Dein Content Type wird irgendwie nicht richtig gesetzt.

Ersetze mal den entsprechenden http-equiv durch sowas hier:

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

greez 8)
JoSsiF

Danke, aber leider hat das auch nichts gebracht...


« Musik URLSuche Sript für Seitenweiterleitung, falls bestimmste site nicht aufgerufen wird »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

| Mehr Themen zu "MySQL"
Fremdwörter? Erklärungen im Lexikon!
PHP
PHP steht für Personal Home Page und ist eine Skriptsprache die meist verwendet wird zur dynamischen Erzeugen von Internetseiten. PHP zeichnet sich durch die weite D...

AppleScript
AppleScript ist eine Programmiersprache von Apple für Skripte und Programme auf Systemebene. Im Gegensatz zu den Unix-Shellscripts, die seit OS X ebenfalls mögl...

Javascript
Javascript ist eine von Netscape entwickelte Skriptsprache für den Einsatz für DOM-Scripting auf Webseiten. Nahezu alle Browser- und Webseiten-Elemente lassen s...