Computerhilfen.de Logo
Forum
Tipps
News

Suse: openSuSE 11.0 und GoogleEath

Unter SuSE 10.3 hatte ich GoogleEarth bereits funktionsfähig installiert. Nach dem Update auf 11.0 funktioniert es aber nicht mehr. Auch eine Neuinstallation (wie in einem anderen Beitrag erläutert) brachte keinen Erfolg.

Wenn ich GoogleEarth aufrufe, steigt die Susi aus und ich befinde mich in der Anmeldemaske. Was kann da schief laufen?

Gruß Hermann


Antworten zu Suse: openSuSE 11.0 und GoogleEath:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

mindestens OpenGL muss aktiv sein. Prüfe ob die Mesa Pakete ( ohne -devel ) alle installiert sind. Als Font wird von Google Earth Bitstream Vera benötigt.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Danke für Deine Antwort Dr. SuSE -
mesa 7.0.3-35.1 und Bitstream Vera sind installiert. OpenGL kann ich als eigenständige Anwendung nicht finden...

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

Mesa und OpenGL, könnte da nicht ein Zusammenhang bestehen ??

Nur mal so zur Info:
Mesa 3D ist eine freie Grafikbibliothek, die die OpenGL-Spezifikation umsetzt und auf vielen Betriebssystemen genutzt wird, um OpenGL-Funktionalität zu implementieren.

Somit wirst Du keine eigenständigen OpenGL Pakete finden:  ;)

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Inzwischen habe ich mich etwas in Mesa und OpenGL eingelesen. Allerdings erschließt sich mir trotzdem nicht, wieso GoogleEarth auf SuSE 11.0 nicht funktioniert (sehr wohl aber vorher mit SuSE 10.3).

Eigentlich habe ich mich doch bei der Installation genauso verhalten, wie bei der "alten" Version.

Gruß Hermann

« Letzte Änderung: 13.07.08, 20:55:15 von oldy_but_goody »
Zitat
Dr. SuSE schrieb: mindestens OpenGL muss aktiv sein.

Hat mich auch gewundert, war bis zur 10.3 noch nicht so. Hier lief Google Earth logischerweise zwar extrem langsam, aber es lief, während unter der 11.0, ohne aktiviertes OpenGL, der komplette X-Server beim Start von Google Earth abgeschossen wird.
 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

Du musst schauen, ob 3D der Grafikkarte auch eingeschaltet ist! Wenn 3D nicht läuft, bleibt Google Earth beim Startbildschirm hängen.

Ob du auf die freien (nvidia-nouveau ,xorg-x11-driver-radeonhd ) Xorg Treiber oder auf die propritären von Nvidia oder ATI setzt musst Du für dich entscheiden. Funktionieren tut's mit beiden

Wie weit kommst Du mit der "Google Erde" überhaupt ? Wo hakt es speziell ? 

Have Fun

 

Zitat
Dr. SuSE schrieb:  Wie weit kommst Du mit der "Google Erde" überhaupt ?

Bis KDM!

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Dr. SuSE,

jetzt kommen wir der Sache langsam näher:

Folgende Treiber sind installiert
   nouveau-kmp-default
   xorg-x11-driver-video-nouveau-3d

Bei Aufruf von sax2 sehe ich, daß 3d-Beschleunigung  nicht aktiviert ist. Kann auch nicht angewählt werden, da nur grau sichtbar.

Die gleiche Grafikkarte war unter 10.3 sehr wohl 3d-fähig. Trat hier unter 11.0 eine  Verschlimmbesserung ein? Ich konnte auch durch Experimentieren mit den Auflösungen und der Farbtiefe keine Möglichkeit entdecken, 3d zu aktivieren.

Übrigens: bei Aufruf von GoogleEarth kommt nur dessen Startfenster (ohne jegliche weitere Aktivitäten) - dann steigt Susi kommentarlos aus und ich bin wieder im Anmeldebildschirm.[/blue]

Sieht fast so aus, als ob ich mir eine neue AGP-Grafikkarte (Mainboard siehe Signatur) zulegen müßte. Die bisherige (siehe Signatur) habe ich wegen der vorher benötigten Win98SE-Kompatibilität gebraucht (jetzt WinXP).
Habe mir die Power Color (Retail) HD3650 512MB 2xDVI/TV als Kandidaten ausgesucht (€ 67,19). Was hältst Du von der? [/blue]

Gruß Hermann

Nur damit keine Gerüchte aufkommen:

GoogleEarth läuft mit dem originalen Nvidia-Treiber und der GT6600 PERFEKT unter der openSUSE 11.0, genauso wie unter allen bisherigen openSUSE Vers.

Wer EXPERIMENTELLE Treiber benutzt, sollte sich nicht wundern wenn das zu Problemen führt.
 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Habe eben die Nvidia-Seite http://download.nvidia.com und das Verzeichnis /opensuse/11.0 bei den Installationsquellen hinzugefügt.

Anschließend per Software installieren oder löschen nvidia-gfxG01-kmp-default (173.14.09_2.6.25.5_1.1-0.1) installiert. Mit diesem Treiber ist in sax2 automatisch das Kästchen  3d-Unterstützung aktiviert.

Jetzt kann GoogleEarth gestartet werden. Der Seitenaufbau ist allerdings erheblich langsamer als bei SuSE 10.3

Sollte ich es evtl. doch mit der oben beschriebenen neuen Graka versuchen?

Gruß Hermann

« Letzte Änderung: 14.07.08, 18:55:08 von oldy_but_goody »

 

Zitat
Der Seitenaufbau ist allerdings erheblich langsamer als bei SuSE 10.3

Nur mit der Vers. 4.3, nicht mit der 4.2. Ist ja unter der 10.3 nicht anders.

 
Zitat
Sollte ich es evtl. doch mit der oben beschriebenen neuen Graka versuchen?

Kannst kaufen was Du willst, ist aber mehr als sinnlos. Selbst die GT6600 ist schon überdimensioniert. 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Bei mir ist GoogleEarth Version 4.2.0205.5730 installiert. Sollte eigentlich flüssiger laufen.

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

falls noch nicht geschehen, würde ich mal die Installationsquelle für xorg 7.3 in yast hinzufügen und mesa,libdrm und die ganzen x11-xorg Pakete auf den neuesten Stand bringen. An Xorg wird derzeit heftig programmiert und mal läuft es runder, ein anderes mal hakelt es ein wenig, je nach Versionsstand. Die Pakete, welche mit openSUSE_11.0 bei der Installation installiert werden, stammen vom Mai des Jahres. Zwischenzeitlich ist viel Entwicklungsarbeit geleistet worden und auch etliche Bugs wurden beseitigt.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Dr. SuSE,
danke für Deine Antwort. Damit hast Du den Nagel auf den Kopf getroffen! Die Xorg-Repositories hatte ich doch glatt vergessen (mea culpa) *schäm*

Jetzt rennt GoogleEarth wieder!

Zusatzfrage: Ich habe die Installationsquellen "händisch" nach der Auflistung für OpenSUSE 11 hinzugefügt. Sollten zusätzliche Community/Gemeinschafts-Repositories installiert werden? Bei der Aktualisierung hatte ich diesen Aspekt schlicht übersehen...

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

na ja, kann ja mal passieren. Solange du hier kein >Confiteor< los lässt, geht's ja noch.  ;)
Hauptsache Du bist nun mit der Performance zufrieden. Was die Repos betrifft, wenn Du die aus der Liste hier eingetragen hast, sollte das voll ausreichen.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

möchtest Du die Gewschwindigkeit Deiner Nvidia noch mehr steigern, musst Du ein paar Parameter setzen und zwar diese in eine Rootkonsole tippen:

nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1 ENTER

Damit man das nicht bei jedem Neustart des Xservers machen muss, kann man dies auch in die Konfigurationsdatei /etc/X11/xorg.conf in der Section "Device" mit Rootrechten eintragen. Dann geht's automatisch.

Section "Device"
Option "InitialPixmapPlacement" "2"
Option "GlyphCache" "1"
EndSection

Nutzer von Compiz sollten in die Datei .bashrc in Ihrem Homeverzeichnis mit einem Editor  noch folgendes hinzufügen:

export KWIN_NVIDIA_HACK=1

Dann wird Compiz in Verbindung mit Nvidia hübsch schnell.

Hier gibt es noch ein paar mehr Performance-Tipps für KWin:
http://techbase.kde.org/User:Lemma/GPU-Performance

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Verbindlichen Dank Dr. SuSE,
habe Deine Tipps umgesetzt - jetzt ist meine Nvidia Graka tatsächlich richtig schnell geworden.

Ich komme mir vor, als hätte ich einen anderen PC...

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Hermann,

na siehst Du, brauchst gar keine andere Grafikkarte. Die vorhandene muss nur richtig eingestellt sein.  :D

Have Fun


« Suse: Absoluter Anfänger braucht Hilfe bei NTFSSuse: SAMBA neuling »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!