Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

 :)

 Hallo,

Hab noch was anderes

 vielleicht hilft Dir das wenn Du es noch mal versuchen solltest.

http://penguin-breeder.org/sane/mustek_pp/


   root #  ls /proc/sys/dev/parport/
 . .. default parport0
 kommt die Meldung ist der parport aktiviert



root #  sane-find-scanner -p

hier müßte der Scanner erkannt werden.

Viele Grüße

OK, ich versuchs demnächst nochmal. Bei Erfolg werde ich mich umgehend wieder melden. Bei Nichterfolg wird es der Scanner wohl nicht überleben! >:(
Danke jedenfalls.
Gruß

@ Wilfied: ES GEHT!!
@Urmelchen: 1000 Dank. Dein letzter Beitrag hat's gebracht. Parport0 wird erkannt. In der mustek_pp.conf wird nur der Eintrag 0x375 nicht erkannt und muß durch parport0 einfach ersetzt werden. Endlich ist der allerletzte Grund für mich mein Windows noch nicht zu entsorgen weggefallen.
Vielen Dank!!
Gruß
Ned

 :):)

Hallo,

Glückwunsch ;D

kannst Du bitte die mustek_pp.conf mal posten wegen dem Eintrag wie Sie aussehen muss.  
 ;)Vielleicht braucht es der eine oder andere dann weis er (wie, was, wo, ....,)
Danke im Voraus
Viele Grüsse  ;)

Hm dann sieht die mustek_pp.conf so aus?
#
# Example for Mustek 6000P
#
scanner 6000P parport0 ccd300     anstelle von 0x378  parport0
#   option top 56
#
#

Hm das mit parport0 eintragen anstelle von 0x378 das könnte auch bei anderen funzen mal so eine überlegung



« Letzte Änderung: 02.10.04, 13:24:26 von urmelchen »

Ja, genau. Hier ist mein Eintrag:

scanner Mustek_SE6000P parport0 ccd300

Dieser Eintrag war nirgends als Lösung zu finden. Ich denke schon, dass auch andere danach suchen.
Also, ich hatte das ja schon ausprobiert mit verschiedenen Portbezeichnungen. Da fehlte mir aber noch die libieee, danach war dessen Installation falsch, also noch mal neu. Irgendwann war wohl alles richtig, nur die Portbezeichnung war eben wieder original.
Naja, nu geht's!
 :D

« Letzte Änderung: 02.10.04, 15:58:22 von ned_devine »

 :):)

Hallo,

 Glückwunsch
 Na das ja eigentlich schon interessant das die genaue Scannertyp drin stehen muß den in vielen Thread's hab ich schon gelesen aber da stand dann wie bei Dir bspw. scanner  6000P   ohne das mit dem Mustek_SE
Hm deshalb ist es auch möglicherweise dann daran gescheitert das es doch irgendwie doch nicht gehen wollte möglicherweise wird es vielleicht HM braucht man es irgendwie als eine Art Verbindungsglied oder um irgendwie so eines zu erzeugen.

Also die genau Bezeichnung des Scanner's eintragen kann anscheinend nötig sein beim Parallelport so wie es aus sieht.

     ;D Werd's Mir merken

Viele Grüsse

ps. und viel Output ;)

Ja, das scannt klasse, hoffentlich liest Wilfried das hier alles. :D
Geht noch besser als mit meinem Mandrake und der älteren Sane-Version! Damit hatte ich übrigens die Einstellungen verglichen. Da war alles original wie beschrieben. Portbezeichnung 0x378.
Gruß

Hallo,

ja, ich lese noch mit. Das mit der Bezeichnung vom ParallelPort habe ich so ähnlich auch schon gemerkt. In der modules.conf habe ich mal die Kommentare gelesen. Dort stand, das mit dem Linux-Kernel 2.4.x die Bezeichnung 0x378 nicht mehr gültig ist. Und die Bezeichnung lp0 ist mit der libieee1284 nicht mehr gülitg. Ging auch nicht. Aber die Bezeichnung parport0 tut's jetzt. Zumindest wird der Anschluß nun erkannt bzwe. geöffnet.

Aber wenn ich xsane starte, dann wird mein Scanner immer noch nicht erkannt  :-(  .
Deshalb hatte ich das noch nicht gepostet.

Ich werde es mal so konfigurieren wie ned_xxx.

Dazu aber noch eine Frage. Hier wird immer von der mustek_pp.conf geschrieben. Dort wird auch ein Treiber ccd300 aufgeführt. Laut Recherche sollten die ccd-Scanner aber in der mustek_pp_ccd.conf stehen. Der ScanExpress 6000 P steht auch dort bei mir. Aber ohne den erwähnten Treiber ccd300. Dafür finden sich aber in /usr/lib/sane (o. ä.) die zugehöringen Treiber. Ich glaube so ähnlich wie sane_mustek_pp_ccd.so.

Kann da jemand was zu sagen?

Grüße
Wilfried

Hallo Wilfried,
bei mir läuft die mustek_pp_ccd.conf jedenfalls so nicht, auch wenn ich den Port als parport0 angebe. Habe noch nicht weiter herumexperimentiert. Ich denke, dass ich die Einstellungen einfach so lasse. Das sollte doch bei Dir auch laufen.  

Hallo ned_devine,

heute Abend hab ich's noch mal versucht. Aber leider erfolglos. In der mustek_pp_ccd.conf weiß ich nicht den Treiber ccd300 einzubringen.

Ich würde meinen Rechner bezüglich des Scanners gerne mal genau so einrichten wie Deinen. Kannst Du mir bitte mal Deine dll.conf, mustek_pp.conf, mustek_pp_ccd.conf und modules.conf zukommen lassen? Email: wibr@gmx.de

Hast Du eigentlich auch die Sane Version 1.0.13 für SL9.0 oder schon die V1.0.14 für SL9.1 installiert? Falls schon V1.0.14, läuft bei Dir SL9.0 oder SL9.1?

Vielen Dank und liebe Grüße
Wilfried

Hallo Wilfried,

bin gerade nicht am Rechner, maile Dir die Dateien heute Abend zu.
Ich habe Suse 9.1 mit Sane 1.0.14. Die mustek_pp_ccd.conf läuft bei mir wie gesagt auch nicht.
In der mustek_pp.conf lautet der Eintrag wie oben beschrieben. Ich schick Dir die Dateien aber nachher.
Gruß

Ned

Hallo ned_devine,

gerade habe ich SuSE 9.1 installiert. Dann die libieee1284 und danach sane V1.0.14. Die dll.conf und mustek_pp.conf habe ich hoffentlich wie hier beschrieben konfiguriert. Natürlich auch rcsane restart bzw. sogar einen Reboot des Rechners.

Es hat wohl gebracht, dass der parport anscheinend korrekt geöffnet werden kann. Aber der Scanner wird nach wie vor nicht erkannt :-( .

Hier mal Debug-Meldungen zum kommentieren:
linux:/etc/sane.d # scanimage -L
[sanei_debug] Setting debug level of mustek_pp to 128.
[mustek_pp] sane-mustek_pp, version 0.13-beta. build for SANE 1.0.14
[mustek_pp] backend by Jochen Eisinger <jochen.eisinger@gmx.net>
[sanei_debug] Setting debug level of sanei_pa4s2 to 128.
[sanei_pa4s2] sanei_pa4s2: interface called for the first time
[sanei_pa4s2] sanei_pa4s2_open: called for device 'parport0'
[sanei_pa4s2] sanei_pa4s2_open: trying to connect to port
[sanei_pa4s2] pa4s2_open: trying to attach dev `parport0`
[sanei_pa4s2] pa4s2_init: static int first_time = 1
[sanei_pa4s2] pa4s2_init: called for the first time
[sanei_pa4s2] pa4s2_init: initializing libieee1284
[sanei_pa4s2] pa4s2_init: 1 ports reported by IEEE 1284 library
[sanei_pa4s2] pa4s2_init: port 0 is `parport0`
[sanei_pa4s2] pa4s2_init: allocating port list
[sanei_pa4s2] pa4s2_init: initialized successfully
[sanei_pa4s2] pa4s2_open: looking up port in list
[sanei_pa4s2] pa4s2_open: port is in list at port[0]
[sanei_pa4s2] pa4s2_open: setting up port data
[sanei_pa4s2] pa4s2_open: name=parport0 in_use=SANE_TRUE
[sanei_pa4s2] pa4s2_open: enabled=SANE_FALSE mode=PA4S2_MODE_NIB
[sanei_pa4s2] pa4s2_open: opening device
[sanei_pa4s2] pa4s2_open: device `parport0` opened...
[sanei_pa4s2] pa4s2_open: returning SANE_STATUS_GOOD
[sanei_pa4s2] pa4s2_open: open dev `parport0` as fd 0
[sanei_pa4s2] sanei_pa4s2_open: connected to device using fd 0
[sanei_pa4s2] sanei_pa4s2_open: checking for scanner
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 1
[sanei_pa4s2] sanei_pa4s2_enable: enable port 'parport0'
[sanei_pa4s2] pa4s2_enable: prelock[] = {0x18, 0x8f, 0x0c}
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: reading ASIC id
[sanei_pa4s2] sanei_pa4s2_readbegin: called for fd 0 and register 0
[sanei_pa4s2] sanei_pa4s2_readbegin: NIB readbegin
[sanei_pa4s2] pa4s2_readbegin_nib: selecting register 0 at 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbegin: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbyte: called with fd 0
[sanei_pa4s2] sanei_pa4s2_readbyte: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readbyte: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readbyte: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readbyte: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readbyte: read in NIB mode
[sanei_pa4s2] pa4s2_readbyte_nib: reading value 0xa8 from 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbyte: read finished
[sanei_pa4s2] sanei_pa4s2_readbyte: got value 0xa8
[sanei_pa4s2] sanei_pa4s2_readbyte: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readend: called for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readend: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readend: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readend: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readend: NIB mode readend
[sanei_pa4s2] pa4s2_readend_nib: end of reading sequence for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: detected ASIC id 1013
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 0
[sanei_pa4s2] sanei_pa4s2_enable: disable port 'parport0'
[sanei_pa4s2] pa4s2_disable: state restored
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: trying better modes
[sanei_pa4s2] sanei_pa4s2_open: trying mode 0
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 1
[sanei_pa4s2] sanei_pa4s2_enable: enable port 'parport0'
[sanei_pa4s2] pa4s2_enable: prelock[] = {0x18, 0x7f, 0x0c}
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbegin: called for fd 0 and register 0
[sanei_pa4s2] sanei_pa4s2_readbegin: NIB readbegin
[sanei_pa4s2] pa4s2_readbegin_nib: selecting register 0 at 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbegin: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbyte: called with fd 0
[sanei_pa4s2] sanei_pa4s2_readbyte: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readbyte: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readbyte: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readbyte: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readbyte: read in NIB mode
[sanei_pa4s2] pa4s2_readbyte_nib: reading value 0xa8 from 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbyte: read finished
[sanei_pa4s2] sanei_pa4s2_readbyte: got value 0xa8
[sanei_pa4s2] sanei_pa4s2_readbyte: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readend: called for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readend: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readend: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readend: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readend: NIB mode readend
[sanei_pa4s2] pa4s2_readend_nib: end of reading sequence for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 0
[sanei_pa4s2] sanei_pa4s2_enable: disable port 'parport0'
[sanei_pa4s2] pa4s2_disable: state restored
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: mode works
[sanei_pa4s2] sanei_pa4s2_open: skipping mode UNI
[sanei_pa4s2] sanei_pa4s2_open: trying mode 2
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 1
[sanei_pa4s2] sanei_pa4s2_enable: enable port 'parport0'
[sanei_pa4s2] pa4s2_enable: prelock[] = {0x18, 0x7f, 0x0c}
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbegin: called for fd 0 and register 0
[sanei_pa4s2] sanei_pa4s2_readbegin: EPP readbegin
[sanei_pa4s2] pa4s2_readbegin_epp: selecting register 0 at 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbegin: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbyte: called with fd 0
[sanei_pa4s2] sanei_pa4s2_readbyte: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readbyte: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readbyte: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readbyte: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readbyte: read in EPP mode
[sanei_pa4s2] pa4s2_readbyte_epp: reading value 0xa8 from 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbyte: read finished
[sanei_pa4s2] sanei_pa4s2_readbyte: got value 0xa8
[sanei_pa4s2] sanei_pa4s2_readbyte: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readend: called for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readend: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readend: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readend: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readend: EPP mode readend
[sanei_pa4s2] pa4s2_readend_epp: end of reading sequence
[sanei_pa4s2] sanei_pa4s2_readend: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 0
[sanei_pa4s2] sanei_pa4s2_enable: disable port 'parport0'
[sanei_pa4s2] pa4s2_disable: state restored
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: mode works
[sanei_pa4s2] sanei_pa4s2_open: using mode 2
[sanei_pa4s2] sanei_pa4s2_open: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 1
[sanei_pa4s2] sanei_pa4s2_enable: enable port 'parport0'
[sanei_pa4s2] pa4s2_enable: prelock[] = {0xff, 0x8f, 0x0c}
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbegin: called for fd 0 and register 0
[sanei_pa4s2] sanei_pa4s2_readbegin: EPP readbegin
[sanei_pa4s2] pa4s2_readbegin_epp: selecting register 0 at 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbegin: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbyte: called with fd 0
[sanei_pa4s2] sanei_pa4s2_readbyte: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readbyte: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readbyte: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readbyte: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readbyte: read in EPP mode

An dieser Stelle hängt sich der Rechner bzw. scanimage weg. Das weghängen passiert aber auch bei xsane. Muss eigentlich noch etwas anderes als libieee1284 und sane V1.0.14 installiert oder aktualisiert werden?

Ned_devin, nun warte ich ab, bis ich Deine *.conf Dateien bekomme. Es MUSS doch gehen!

Grüße
Wilfried

 :)

    Hallo,

   im Verzeichnis  /etc/sane.d/mustek_pp.conf

 vorher
  # Example for Mustek 6000P
  #
  #    scanner 6000P 0x378 ccd300
  #        option top 56


 nachher
  # Example for Mustek 6000P
  #
  scanner Mustek_SE6000P parport0 ccd300
  #        option top 56


im Verzeichnis   /etc/sane.d/sane.dll

 muss vor allen Einträgen ein  # < Kommentarzeichen>  sein
 Nur vor dem mustek_pp  da darf keines sein

 so muss es aussehen
  # microtek2
  # mustek
  mustek_pp
  # mustek_usb
  # nec
  # pie

   im Verzeichnis    /etc/modprobe.conf


   vorher
   alias parport_lowlevel parport_pc
   # options parport_pc io=0x378 irq=none,none

   nachher
    alias parport_lowlevel parport_pc
    options parport_pc io=0x378 irq=none,none
   
  Viel Erfolg
  Viele Grüsse
   

Hallo Wilfried,
hab's gestern nicht mehr an meinen Rechner geschafft. Aber Urmelchens Beschreibung ist genau richtig. Allerdings hatte ich beim Start von rcsane noch eine Fehlermeldung und musste erst "rcslpd start" aufrufen. Danach dann "rcsane restart".Das kann man dann aber später im Runlevel-Editor anpassen.  


« Andere: leerzeichen in shellSuse: 9,0PCI-Soundkarte von Phillips »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Directory
Ordner im Dateisystem eines Computers. Siehe auch Ordner ...

Scanner
Der Scanner, vom englischen to scan "abtasten" ist ein Gerät, mit dem sich Bilder und Fotos digitalisieren und in den Computer einlesen lassen. Die Daten können...

Grundstrich
Der Begriff des Grundstrichs im Bereich der Typografie, bezeichnet den senkrechten Strich der Buchstaben. Bei Schriftarten mit variabler Strichstärke, wie zum Beispi...