Computerhilfen.de Logo
Forum
Tipps
News

Langes Netzwerkkabel - schlechte Verbindung mit Raspberry Pi

Hallo Leute,

seit ca. 3 Jahren betreibe ich einen Raspberry Pi, der per USB eine Fotokamera steuert, alle 20 Min. ein Foto schießt, das Foto automatisch bearbeitet und es auf eine Website stellt.
Der Raspberry Pi (Modell B) ist über eine langes LAN-Kabel (ca. 30 Meter) an einer Fritz!Box 7170 angeschlossen und als Betriebssystem auf dem Pi dient Slackware ARM 14.0.

Mein Problem ist, dass die Netzwerkverbindung zwar stabil ist, es aber zu Aussetzern von teilweise mehreren Minuten kommt. D.h. die Verbindung wird nicht abgebrochen, nur werden keine Daten übertragen. Das hat zu Folge, dass die Foto-Serie manchmal nicht vollständig ist, also Fotos fehlen.

Ein Kuriosum dabei ist für mich, dass wenn ich z.B. meinen Laptop über dieses Netzwerkkabel anschließe, die Verbindung hervorragend zu sein scheint. Wenn ich aber das LAN-Kabel direkt an den Pi anschließe, ist gar keine Verbindung (zur Fritz!Box) möglich. Um eine Verbindung mit dem Pi zu bekommen, muss ich einen LAN-Switch benutzen, also:
Fritz!Box -> langes Kabel -> Switch -> kurzes Kabel -> Rapberry Pi [???]
Das funktioniert bei mir aber nur mit einem Noname-Switch. Über einen Router (als Switch) und einen Switch, die beide von Netgear sind, konnte ich keine Verbindung bekommen.
Habe es übrigens mit zwei Pis getestet und bei beiden tritt dieses Problem auf.

Wie lässt sich das erklären? Ist das Signal zu schwach für den Pi? Ist die Hardware im Pi zu schlecht? Und warum funktioniert das mit dem Switch, aber nicht mit jedem?

PS. WLAN wäre für mich in dem Fall keine Option



Antworten zu Langes Netzwerkkabel - schlechte Verbindung mit Raspberry Pi:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
1 Leser hat sich bedankt

das liegt daran, daß die Fritz Spannung und Strom "rausschickt" und so die Strecke versucht zum "Stehen" zu bringen. Der Laptop schickt ebenfalls eine Spaanung raus. Beide mit einer gewissen maximalen Stromstärke. Wir diese bei der Fritz überschritten, brennt der Port oder im ungünstigsten Fall die Fritz elbst durch. Der PI sendet in diesem Falle kein Strom.

Vielen Dank für die Erklärung.

Heißt das also, dass der Switch auch Spannung rausschickt und deshalb die Verbindung vom Pi zur Fritz möglich ist?

Nun wird die Verbindung, zwar gehalten, kommt aber gelegentlich ins Stocken. An manchen Tagen scheinen die Pausen öfter oder länger zu sein als an anderen Tagen.
Was könnte ich versuchen, um eine saubere Verbindung zu bekommen? Noch einen Switch z.B. auf halbem Weg installieren oder welche Möglichkeiten gibt es dafür?

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Einen Switch dazwischen hängen ( mit eigener Stromversorgung/ Netzteil) bzw. einbinden. Dieser sollte dann als "Verstärker" fungieren. Ich hoffe, Du hast auch richtiges LAN-Kabel verwendest und nicht selber mit irgendwelchen Kabel frei verlegt. Vor allen bei längeren Strecken sollte man ausgeschriebenes LAN-Kabel verwenden.


« von domäne zurück zur arbeitsgruppeWlan am Laptop kaputt »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!