Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Windows XP: USB-Eintrag / Gerätekennung entfernen

Beim Installieren eins Druckertreibers wurde versehentlich die Aktion 'Treiber automatisch installieren' geklickt. Der Treiber läßt sich nicht richtig installieren. Jetzt kommt jedes Mal beim anschließen des DruckerUSB die automatische Hardwareerkennung. An welcher Stelle kann der Eintrag zum USB-Gerät gelöscht werden, damit der Hardwareassistent bei 'null' abgebrochen werden kann, die Installation also 'jungfräulich' beginnen kann?


Mein Computer-System:
   
Mein PC ist etwa 0-2 Jahre alt.


Letze Aenderungen bevor der Fehler auftrat:
USB Drucker angeschlossen
Hardwareassistent NICHT abgebrochen
Hardwareassistent "software automatisch installieren" gewählt
Treiberinstallation startet von CD
Treiberinstallation wird mit Fehler beendet
USB Drucker ausstecken
PC neu booten
USB Drucker einstecken
Hardwareassistent startet sofort mit "FS-1300D" gefunden
Hardwareassistent endet mit "bei der Installation ist ein Fehler aufgetreten"
Der Drucker wird nicht in "Drucker & Faxgeräte" aufgeführt
Versuche, den Treiber MIT Hardwareassistent direkt von CD zu installieren bringen gleiche Fehlermeldung "Fehler bei der Installation"


Die Installation hat auf 2 weiteren Rechnern einwandfrei funktioniert weil ich dort den Hardwareassistenten richtigerweise sofort abgebrochen habe.

Ich meine mich zu erinnern dass es in der Systemsteuerung einen Punkt gibt (zumindest für USB-Sticks) wo die Kennung des Gerätes abgelegt wird. Solange diese Kennung gefunden wird startet der Assistent nicht "from scratch".

Für Ihre Bemühungen vielen Dank im Voraus

KU Börder



Antworten zu Windows XP: USB-Eintrag / Gerätekennung entfernen:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Systemsteuerung->System->Hardware->Geräte-Manager öffnen.
Ansicht: ausgeblendete Geräte anzeigen.
Bei gelben Fragezeichen: Eigenschaften kontrollieren, Treiber deinstallieren. Dann nochmals nach Anweisung des Herstellers Setup durchführen und das Gerät zum richtigen Zeitpunkt anschließen. 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

so, angemeldet.


Systemsteuerung->System->Hardware->Geräte-Manager öffnen.
Ansicht: ausgeblendete Geräte anzeigen.
Bei gelben Fragezeichen: Eigenschaften kontrollieren, Treiber deinstallieren. Dann nochmals nach Anweisung des Herstellers Setup durchführen und das Gerät zum richtigen Zeitpunkt anschließen.

Danke für die schnelle Antwort, aber diese "einfachen" Sachen hab ich alle schon hinter mir.Es gibt kein gelbes Ausrufezeichen und keinen Treiber zum deinstallieren, weil die Installation ja fehl geschlagen ist. Deshalb auch kein Drucker im "Drucker & Faxgeräte Fenster".

Das ist ja das Problem: WinXP legt irgendwo zu jedem jemals eingestöpselten USB-Gerät die Kennung ab. Beim nächsten Einstöpseln ----- "Ahh, den kenn' ich doch ...."

Anhand dieser Kennung "weiß" XP jetzt, "da ist der FS-1300D, der war schon mal dran aber .... dem seinen Treiber muss ich noch machen .....". Genau DAS kriegt WinXP aber nicht hin. Also muss ich WinXP dazu bringen, den FS-1300D wieder zu "vergessen", damit dann die richtige Reihenfolge des Herstellers eingehalten werden kann.

Ich suche also die Liste aller USB-Kennungen in der Computerverwaltung (oder wo auch immer). Da stehen alle Speichersticks, Scanner, Fotoapparate etc drin, die jemals angeschlossen waren.

Gruß vom Rhein

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Führe mal dieses Tool nach Anweisung aus:

http://usb-fehlerbehebung.soft-ware.net/download.asp

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Vielen Dank für den Hinweis, leider .....

am Anfang bestand Hoffnung, denn ein USB-Anschluss mit Angabe FS-1300D in den Eigenschaften wurde tatsächlich angezeigt. Nach Durchführung des Programms bleibt das Problem weiterhin: der Drucker wird sofort als "schon einmal angeschlossen" behandelt. Will sagen, der Hardwareassistent kommt direkt wieder mit "neue Hardware gefunden, FS-1300D". Der Assistent scheint das Erkennen des Druckers durch die Installationsroutine zu blockieren.

Bei korrekt durchlaufender Installation wird neue USB Hardware erkannt, der Assistent erscheint mit seiner Anfrage "Windows update ....". Wird dieser Hardwareassistent jetzt abgebrochen (X) läuft die Installation des Treibers von der Original-CD an. Bei ca 87% erfolgt eine Abfrage "Drucker am USB angeschlossen?" und die Routine läuft weiter. In meinem Fall erschjeint der Hinweis: "Bitte Drucker anschliessen, das Dialogfeld wird automatisch geschlossen wenn der Drucker erkannt und der Treiber installiert wurde". An dieser Stelle bleibt das Programm hängen und nach einigen Sekunden kommt in der Taskleiste der Hinweis "Fehler beim Installieren der neuen Hardware." Trotz des kleinen Tools "weiß" der HWassi immer noch, dass der FS-1300D "schon einmal angeschlossen war". Und das steht in dieser  ??? ::) ??? Liste in den Tiefen der Systemsteuerung, NICHT Gerätemanager, die ich nicht mehr finde. Bei USB-Sticks steht da u.A. der Hersteller, z.B. Lexar oder Jumpdrive oder Ä.

Ich könnt ...... 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

so, ein kleiner Schritt weiter: die Liste die ich im Kopf hatte ist in Win2000 an dieser Stelle zu finden, jetzt ist die Frage WO stehen diese Infos in WinXP


 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Problem gelöst: Über MMC konnte der virtuelle Port USB0003 als dem KYO zugeordnet "erahnt" werden.

Über "Start-Einstellungen->Drucker&Faxgeräte->Neuen Drucker installieren->Druckeranschluss USB0003->Treiber auf CD wählen->oeminf" hat es GEKLAPPT, der Drucker ist da und läuft.
 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

getrübte Freude: der Drucker klappt zwar, aber dieses  :-X::) ??? :o:-\ XP meckert jedes Mal beim Hochfahren, dass neue Hardware erkannt wurde und beim Installieren der Hardware ein Fehler aufgetreten ist. 

, jetzt ist die Frage WO stehen diese Infos in WinXP
Start >>> Systemsteuerung >>> Verwaltung >>>  Computerverwaltung

Meinst du das

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Da stehen diese Infos nicht. Es gibt zwar den Ordner "Ressources", der ist aber leider leer. Wie auf dem screenshot von W2K zu sehen ist, wurden bei W2k dort alle jemals eingestöpselte USB-devices  gespeichert. Löschte man bei W2k an dieser Stelle den Eintrag, verhielt sich W2k so als ob das USB-Gerät zum allerersten Mal connektiert wurde.
Bei XP gibt es mit "Anzeige ausgeblendete Geräte" nur eine Liste mit großen grauen Fragezeichen (NICHT die gelben für "es gibt Probleme"). Die zeigen aber nur die aktuellen Geräte, nicht die komplette "war-irgendwann-schon-mal-angeschlossen" Durch anklicken jedes einzelnen Fragezeichensymbols mit rechter Maustaste kann man u.U. bei "Eigenschaften" ein paar Infos lesen. So habe ich rausgefunden, dass XP den Drucker mit Anschluß USB003 verknüpft hatte und konnte den Treiber manuell und gezielt für USB003 installieren lassen. Schlußendlich ist die Info hinter den Fragezeichen aber noch weniger als schon im Gerätemanager steht. Die glasklare Auskunft wie auf dem W2K-screenshot ist nicht zu bekommen. Das Löschen des betreffenden "Fragezeichens" bringt nicht den gewünschten Erfolg, der Drucker wird nach wie vor sofort (wieder)erkannt.
Hinter dem grauen Fragezeichen steht auch nicht die Herstellerkennung, so wie es auf dem W2k-screenshot zu sehen ist. 

« Letzte Änderung: 30.10.09, 10:08:35 von hannes32 »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hab ein passendes Tool gefunden

http://www.nirsoft.net/utils/usb_devices_view.html

 

Hab ein passendes Tool gefunden

http://www.nirsoft.net/utils/usb_devices_view.html
 

Ich habe (heute, jetzt!) das selbe Problem wie Du. Hat das Tool unter http://www.nirsoft.net/utils/usb_devices_view.html geholfen? Wie hast Du es eingesetzt?

Es grüßt

Joachim

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Joachim,

so richtig "geholfen" hat es nicht, das tool zeigt die jemals angeschlossenen Devices zwar fein säuberlich an, ein "entfernen" scheint dennoch nicht statt zu finden, nur das normale "disconnect". Das war bei WIN2000 anders, da wurden die Infos zum Device komplett entfernt, als ob es nie da gewesen wäre.

Ich kann aber jetzt trotz der Meldung "es ist ein Problem bei der Installation der Hardware aufgetreten" einwandfrei drucken. Irgendwo sitzt immer noch ein Rest der fehlgeschlagenen Erstinstallation.

Tool einfach entpacken und starten, keine Installation nötig.

Gruß vom Rhein


« neues netzteilGehäuselüfter kein Platz mehr zum anstecken! »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Gerätetreiber
Anderes Wort für Treiber....

Treiber
Der Treiber, auch Gerätetreiber genannt, ist ein kleines Steuerungsprogramm für Computerhardware. Treiber sind meist Teil des Betriebssystems und werden fü...

Malware
Mit Malware bezeichnet man allgemein Schadprogramme, die dazu entwickelt worden schädliche Funktionen auf Computern auszuführen. Das Wort setzt sich zusammen au...