Computerhilfen.de Logo
Forum
Tipps
News

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Danke für Deine Antwort Dr. SuSE.
Ich habe in ~/.kde4/share/apps/konqueror umbenannt in konqueror-1
sowie in ~/.kde4/share/config/konquerorrc umbenannt in konquerorrs-1

Gleiches habe ich im Verzeichnis ~/.kde durchgeführt. Danach Neustart.

Datei in .kde4 (konquerorrc) sowie (konqueror) wurde nicht neu angelegt. In .kde wurden obige Dateien neu angelegt.

Nach Neustart ist der Fehler noch immer vorhanden.

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

das sieht nach Unwissenheit aus, oder warum hast du zum Rundumschalg ausgeholt? Das Verzeichnis .kde ist der Aufbewahrungsort für die benutzerbezogenen Konfigurationsdateien von KDE3 Programmen, .kde4 ist gleiches, eben für die KDE4 Versionen. In einem Mischsystem mit KDE3 und KDE4 Apps gibt es beide Verzeichnisse im Homeverzeichnis eines jeden Anwenders. Wenn nun Fehler auftreten kommentiert man einfach testweise nur die relavanten Konfigurationsdateien der jeweiligen KDE Version für den entsprechenden Anwender aus und nicht mal auf Verdacht alle. Ist damit das Problem nicht behoben hilft oft ein komplettes Systemupdate. Stimmen die Installationsrepos für yast, einfach Rootkonsole öffen, zypper up ENTER eingeben und den Bildschirmanweisungen folgen. Danach Neustart und man kann sich an einem aktuellen System erfreuen. Der nicht englischkundige sollte zuerst mal die Rootkonsolenumgebung eindeutschen. Yast-System-Sprache(Language)-Details. Hier die Locale Einstellungen für den Benutzer Root von ctype auf ja(yes) umstellen. Anschliessend yast-Softwareinstallieren oder löschen starten und mindestens folgende Sprachpakete nachinstallieren:

coreutils-lang
util-linux-lang
bash-lang

Nach der nächsten Konsolenanmeldung dankt das System einem die kleine Mühe mit Ausgaben in der Muttersprache.

Have Fun



 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Danke für Deine Antwort Dr. SuSE,
Deine Vermutung bzgl. Unwissenheit ist richtig. Ich bin ein  Nur-User.

Ich benutze nur KDE3, deshalb die dortige Änderung. Da Du schriebst, daß die Basis für KDE3 bereits jetzt KDE4 ist, habe ich die Änderung auch dort durchgeführt.

An dieser Stelle nochmals meine Frage: Müssen bei den Schemata bei KDE4 Basissystem und KDE4 Desktop-Umgebung auch jeweils Kreuzchen gesetzt werden?

Ich habe coreutils-lang und util-linux-lang installiert. Bash-lang konnte ich jedoch nicht finden. Ich habe danach gegoogled und dabei festgestellt, daß bash-lang nur für SuSE 11.2 verfügbar ist. Ist das richtig? Oder kannst Du mir hierzu eine Installationsquelle nennen?

Du schreibst weiter oben, daß kde4-kwin in der Version 4.3.5 vorliegt: ich finde aber nur die Version 4.1.3

Gruß Hermann

« Letzte Änderung: 18.02.10, 15:47:18 von oldy_but_goody »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

oh sorry, stimmt bash-lang ist erst seit openSUSE_11.2 an Bord.
Da ich keine älteren Versionen mehr betreue ist das irgendwie durchgeflutscht.
Was KDE 4 betrifft, da sind wir sogar seit einer Woche schon bei Version 4.4 angekommen. Hab die Quellen hier aber nicht verändert weil es da bei einigen Systemen noch hakelt. Sofern du die Repos für KDE 4.3.5 in yast eingebunden hast, wählst du in yast im Softwaremanagement -Ansicht-Versionen aus. Hier musst du gezielt auf KDE 4.3.5 wechseln, sonst behält die Susie die alte Version bei. Per Konsole geht's aber auch in einem Rutsch:

zypper dup ENTER

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Dr. SuSE,
durch den Befehl zypper dup in der Root-Konsole ist die Sitzungsart KDE3 aus dem Auswahlkmenü verschwunden. Wie kann KDE3 wieder dem Auswahlmenü hinzugefügt werden?

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Inzwischen konnte ich das Problem mit dem nicht mehr im Auswahlmenü erscheinenden KDE3 lösen:

Wie im Beitrag http://www.computerhilfen.de/hilfen-6-290719-0.html#msg1511655 von Dr. SuSE erklärt, habe ich die Pakete
 
kde3-amarok
kde3-digikam
kde3-k3b
kde3-knemo
kde3-gwenview
kde3-kaffeine
kde3-kcm-gtk
kde3-kerry
kde3-kommander
kde3-kommander-runtime
kde3-kssh


mit YaST entsprechend angeglichen. Da nun KDE3 noch immer nicht im Auswahlmenü erschien, überprüfte ich mit YaST mit Software installieren oder löschen unter dem Punkt Schemata die Einträge. Und siehe da: KDE3 war nicht markiert. Also setzte ich bei KDE3 Desktop-Umgebung[/b] und bei KDE3 Basissystem jeweils ein Kreuz. Anschließend aktualisierte ich alle installierten Pakete. Beim Neustart war KDE3 wieder im Auswahlmenü vorhanden. *freu*

Das Problem mit KDEInit besteht jedoch weiterhin!

Wodurch bei den Schemata KDE3 als nicht installiert gekennzeichnet wurde, ist mir völlig schleierhaft, zumal ich mir 100% sicher bin daß beide Kreuze gesetzt waren. Ich bin ja nicht so der experimentierfreudige Typ, deshalb wundern mich diese "selbständigen" Änderungen umso mehr...

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

zypper dup setzt das System auf die neuesten eingetragenen Repos und installiert daraus die Pakete. So dürfte eine automatische Umstellung auf KDE 4 erfolgt sein. zypper entfernt diese Antiquität namens KDE3 nahezu vollständig aus dem System, lässt dich darüber aber nicht im Unklaren. Bevor du mit ja bestätigst gibt es eine entsprechende Liste mit allen angedachten Änderungen. Will man nicht was dort angepriesen wird, ist die logische Konsequenz an dieser Stelle NEIN einzugeben und alles händisch per yast zu erledigen. Du hast jedoch ja gewählt und somit war KDE3 weg. In Zeiten von KDE 4 denkt man nicht mehr unbedingt daran dass es noch einige KDE3 Anwender gibt. Sorry.

KDE init Fehler protokolliert das System in der Datei .xsesion-errors im Homeverzeichnis eines jeden Nutzers. Der Datei kann man entnehmen warum es klemmt.

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Danke für Deinen Hinweis Dr. SuSE.

Den auszugsweisen Inhalt der .xsession-errors habe ich im Beitrag #10 weiter vorne in diesem Thread bereits geposted. Leider kann ich damit gar nichts anfangen - wie gesagt: ich bin nur ein User...
Kannst Du etwas rauslesen, was für das KDEInit-Problem relevant ist?

Gruß Hermann

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Der User khirikhan schreibt im Thread http://www.computerhilfen.de/hilfen-6-316709-0.html Antwort #10, daß die Lösung seines Problems in diesem (dem gerade geöffneten Thread) zu finden war.

Seiner Aussage nach waren fehlende Installationsquellen für KDE4 die Ursache.

Im Beitrag "Installationsquellen" von Dr. SuSE sind 3 Repositories für KDE 4.3.5 benannt. Die Quelle ftp5.gwdg.de/pub/opensuse/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_43 funktioniert jedoch nicht. Wurde diese geändert, ohne die Rubrik Installationsquellen zu aktualisieren?

Gruß Hermann

« Letzte Änderung: 21.02.10, 15:52:00 von oldy_but_goody »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hat hier tatsächlich niemand einen brauchbaren Tip für mich, wie ich den KDEInit-Fehler bereinigen kann? Ich habe mir ja schon fast die Finger wund gegoogled, konnte aber auch dort keinen Volltreffer finden. Wobei mir nach wie vor völlig schleierhaft ist, wodurch dieser Fehler überhaupt ausgelöst wurde. Ich bin nämlich kein Typ, der viel herumexperimentiert.

Wie gesagt - ich bin ein Nur-User. Die Linux-Gurus sollten aber doch in ihrer "Trickkiste" einen Lösungsvorschlag hervorkramen können...

Gruß Hermann

Also das selbe Problem hab ich auch unter KDE 4.4. Und zwar wenn ich den Dolphin als root nutze, kann ich von dort aus zum Beispiel keine config-Datei öffnen. Mit dem Konqueror ist das kein Problem.
Welchen Dateibrowser nutzt du?

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Ssnatcher,
danke für Deine Reaktion. Ich benutze den Konqueror unter KDE3.5 als User. Unter anderen Dateimanagern keine Probleme

Gruß Hermann

Ich habe das gleiche Problem wie Ssnatcher bei:
KDE 4.4 mit Dolphin im Systemverwaltungsmodus.

Sobald ich 'ne Lösung gefunden habe, stelle ich die hier selbstverständlich rein. 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

die Ursache steht meist in der Datei Xsession-errors im Homeverzeichnis. In die berühmte Trickkiste greifen hilft hier leider nicht, sondern nur auswerten der Logdatei(en) und beseitigen der Ursache.

Have Fun

Kein Eintrag in der .xsession-errors.
Habe den Fehler provoziert mit KWrite (Systemverwaltungsmodus mit Dolphin).

Mir ist es jetzt erst aufgefallen, weil ich sonst vi auf der Konsole statt KWrite benutze.

Noch 'ne Idee, wo man suchen könnte?


« Suse: ProblemProblem mit ausführen von Programmen »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!