Computerhilfen.de Logo
Forum
Tipps
News

Suse: Windows booten

Hallo,
ich habe auf meinem Rechner Windows 7 und Suse 11.3 friedlich nebeneinander zum Laufen bewegt. Grub hat beide Systeme sher gestartet. Leider hat mein Board den Geist aufgegeben. Also neues Board und alles Andere so gelassen. Jetzt startet Linux zwar noch einwandfrei. Kleines Manko ich muß das Root-Passwort plötzlich 2 mal eingeben, beim ersten Mal wird immer falsches Passwort gemeldet, aber damit kann ich leben. Allerdings startet Windows nicht mehr. Es kommt die Meldung
map (hd1) (hd0)
map (hd0) (hd1)
rootnoverify (hd1,0)
makeactive
chainloader +1
Dies ist genau der Eintrag wie er in der menu.st stehen müßte und auch steht (Bild 8). Mein  Rechner hat die Konfiguration entsprechend Bild 7.
Wa muss ich in der menu.st ändern?


Antworten zu Suse: Windows booten:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

... die sdb1 ist ja sicher eine aktive Partition.

Versuche mal in der menue.lst

- die map-Zeilen vertauschen
- makeactive auskommentieren   

Da kann er vertauschen was er will, Auswirkungen hat das aber keine. Wer hat das überhaupt da reingeschrieben? „Gemapt“ wird unter openSUSE in der “/boot/grub/device.map“. Aber auch hier kann man reinschreiben was man will, wenn danach kein Setup ausgeführt wird, hat's auch keine Auswirkungen.
Bei nur ZWEI Platten und bei STARTFÄHIGEM openSUSE sollte der W Eintrag übrigens richtig sein. Map gehört da zwar nicht hin, stört allerdings nur die Optik. Bei Generischen Bootcode im MBR bin ich mir nicht 100%tig sicher, macht die SuSE zwar ganz gerne, hab's aber immer rausgenommen. Dazu müsste man noch die “/etc/grub.conf“ sehen und die “/boot/grub/device.map“ wäre auch sehr hilfreich.   

Aber warum lasst ihr das nicht die SuSE machen?

Yast – System – Bootloader – Weitere – Neue Konfiguration vorschlagen – gucken ob richtig – dann OK


Mit “passwd“ kann man übrigens das Root-Passwort (oder andere) neu vergeben
 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,
mit Yast-System-Bootloader-Weitere-Neu Konfiguration vorschlagen habe ich es schon versucht. Bei Auswahl von Windows im Startmenü kommt wieder der bekannte Eintrag
map (hd1)(hd0)
...
und der Rechner bleibt stehen.

Hi,
das hab ich mir doch gedacht (ganz ehrlich, wegen der guten nachträglichen Problembeschreibung  zum Grafikproblem). Mir fallen da zwar spontan noch einige Möglichkeiten ein, die man noch versuchen könnte, aber die hast du sicher auch schon versucht.

Gruß

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

 

Zitat
Da kann er vertauschen was er will, Auswirkungen hat das aber keine. Wer hat das überhaupt da reingeschrieben?

... wahrscheinlich einer, der den Kofler gelesen hat, z.B. "Linux", 7. Auflage, S. 956  ;)

nun gut, wieder was gelernt. Hab's nachgeschaut, betrifft aber nur einen Anwendungsfall der mich fast nur zu 0% interessiert, konnte also passieren. Ich schaue hier ja nicht NUR zum Spaß rein, sondern weil ich mangels eigener Linuxprobleme mir hier welche raussuchen muss. Von daher hatte ich alles wie beschrieben überprüft und mit meinen Möglichkeiten, die mir hier zur Verfügung stehen, nachgestellt. Seltsam. Zumindest hab ich, mal abgesehen von dem für mich nicht relevanten Bereich, jetzt dabei mein Wissen über Grub aufgefrischt und erweitert.

Du kannst ja jetzt mit dem dicken Wälzer in der Hand dieses Problem leicht lösen.

Gruß   

Mist aber auch, unter Ubuntu (Grub2) hätte ich mich rausreden können. Der Befehl heißt jetzt anders und hat noch zusätzliche Parameter.
 


« Suse: Suse: Vodafone USB-Stick Mobile Connect K3565Grafik »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!