Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Mercury Email Server verweigert SSL

Tag zusammen!

Ich habe auf meinem Root-Server im Rechenzentrum einen Mercury Email Server erstellt, da der praktischerweise schon im XAMPP Panel dabei war.

Nun habe ich folgendes Problem:

Versuche ich die Verbindung zum Emails abholen verschlüsselt aufzubauen, verweigert der Server die Verbindung. Auch im Localhost!

Weis jemand, wie ich das umstellen kann? damit am besten nur noch SSL funktioniert und unverschlüsselte Verbindungen verweigert wird?

Derzeit sind verbindungen von außen nicht möglich, ich kann zwar Mails verschicken (getestet an eine @gmail.com) doch ich kann derzeit noch keine Empfangen, da die Domain noch falsch eingestellt ist, und alle Verbindungsanfragen automatisch zum Apache Webserver geleitet werden.

Danke für eure Hilfe!

Vllt. findet sich ja ein Server-Admin der weis, wie das funktioniert :D



Antworten zu Mercury Email Server verweigert SSL:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

SSL Zertifikat vorhanden?? Ja/Nein? Wird irgendwo gehostet und auf den eigenen Server umgeleitet, eigener Server leitet um?? Ja/Nein?

Sonst erst einmal hier lesen:

http://www.schirmacher.de/display/INFO/Apache+SSL+Zertifikat+erstellen

oder hier:

https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=10&cad=rja&uact=8&ved=0CIgBEBYwCQ&url=https%3A%2F%2Fwiki.do.de%2Findex.php%2FVoraussetzungen_f%25C3%25BCr_SSL-Zertifikate&ei=XhSGU6yRHoKwPIWMgLgJ&usg=AFQjCNEJyWhtKFXbYUm7k_fxEdik2pcdPg&bvm=bv.67720277,d.ZWU

oder Zertifikat kaufen und routen.

BTW:

 

Zitat
Root-Server im Rechenzentrum einen Mercury Email Server erstellt, da der praktischerweise schon im XAMPP Panel dabei war.
ROTFL - für sich schon schlimm genug, da wird der Web- und Mailserver eine neue Spamschleuder, XAMPP im Produktivbetrieb ist schon grob fahrlässig, viel Spass bei den bevorstehenden Abmahnungen und Schadenersatzklagen wenn Scriptkids oder arabische Terrororganistionen das Kommando übernehmen und auf dem Ding "Sachen" hosten nach denen die CIA sucht... ;D;D;D
« Letzte Änderung: 28.05.14, 19:09:37 von PWT »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Und warum? Alle logins außerhalb vom Localhost sind sowieso gesperrt und die "Relay" mails hab ich schon geblockt....

Alternativen? so gut wie keine.


Habe jetzt nen anderes problem SSL usw. funkioniert jetzt, aber die Mails kommen nie an, erst bekam ich bei der Testmail ne Email zurück, das der  zugriff verweigert wurde, nunja, hab die Domain umgestellt, weil mir dort immer die DNS IP angezeigt wurde. Somit die Domain umgestellt... jetzt wird die IP richtig weitergeleitet, aber die Mails gehen irgentwo unter...

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

 

Zitat
aber die Mails gehen irgentwo unter...
Logs checken, ohne die kann Dir niemand hier helfen.

 
Zitat
Und warum?
Weil XAMPP für Entwicklungsumgebungen konzipiert/vorkonfiguriert ist und somit nicht für den Produktivbetrieb geeignet ist.

 
Zitat
Alternativen? so gut wie keine.
Selbstverständlich reichlich.
Oder denkst Du, irgendein Server-Admin würde ernsthaft XAMPP einsetzen?? ;)
-> Alles einzeln aufsetzen und entsprechend für den Produktivbetrieb absichern.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Abgesichert ist eigentlich alles PHP usw. sind nur über localhost erreichbar.


Dies habe ich Seitenweise im log, weil ich eine Email von Google erwarte (Test-Mail):

T 20140529 191646 538662f2 Connection from 209.85.220.174
T 20140529 191646 538662f2 EHLO mail-vc0-f174.google.com
T 20140529 191647 538662f2 STARTTLS
T 20140529 191647 538662f2 Connection closed with 209.85.220.174, 1 sec. elapsed.



Und wenn ich versuche eine Mail nach GMX zu verschicken meldet der SMTP_Client END-TO-END, "error during handshake with [IP von GMX]  Connection error"

Nach Google verschicken geht, Empfangen? Fehler oben.
Von GMX Empfangen geht, versenden? Fehler oben.
zu @wegwerfemail.de: Beide richtungen problemlos.
Nach trash-mail.com wird die Mail zwar laut Mercury verschickt, auch angenommen, kommt dennnoch nie an.


Ansonsten bekomm ich Seitenweise Spam in den log, weil so viele Relay anfragen kommen.
Relay für nicht locale mails sind aber deaktiviert, somit Antwortet er auf die Anfrage, wie gewollt, immer: "553 We do not relay non-local mail, sorry."


Google versucht aber immer wieder die Mails zu versenden, doch immer beim "STARTTLS" kommt dann: "connection closed".


« OpenOffice 4.1.0Java : V7 Upd 60 ist da ... »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!