Computerhilfen.de Logo
Forum
Tipps
News

Anker funktioniert nicht

Hallo leute ich habe ein Problem, die bedingungne sind wie folgt, ich habe eine Hompage, die ich am aufbauen bin. Sie besteht aus 3 Frams (Beispiel 1, 2 und 3)
Ich habe nun in Frame 2, dem Fram, bei dem alle berichte Texte usw angezeigt werden einen Bericht erstellt. Dieser Bericht besteht aus mehreren Untertiteln und ist ziehmlich lang. Um dem USER eine rasche Navigation zu ermöglichen habe ich ein Verzeichnis gemacht, am anfang des Berichtes mit den untertiteln. Bei den Untertiteln habe ich Anker gesetzt und diese entsprechend benannt. nun wenn ich im Verzeichniss den Link setze zum Anker fünktioniert dies nur, wenn ich die Seite alleine im Testbrowser anzeigen lasse, wenn ich diese Seite normal mit allen anderen Frams anzeige, geht es nicht, es wird angezeigt, dass die Seite nicht gefungen wird. Ich habe auch schon versucht ein Ziel mit _parent und so weiter anzugeben, was auch ncihts nurzt.

Wieso geht das nicht? mach mache ich falsch? wo liegt mein überlegungsfehler ?

Ich arbeite mit *.PHP

Danke für jede hilfe

Gruss Mur


Antworten zu Anker funktioniert nicht:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
Also mit welchem Editor arbeitest du denn ?

Also zum Thema Anker hier mal eine kleine Anleitung :

Am Besten scrollst du im Quelltext bis zu der Stelle, an dem der Anker gesetzt werden soll, dort fügst du dann folgendes ein :


<a name="ANKERNAME"></a>
Den Link zu diesem Anker heißt dann SEITE.php#ANKERNAME

Meld dich dann nochmal, wenns immernoch nicht funktionieren sollte

Ich arbeite mit dreamweaver MX

Dies ist mein Anker:
<a name="top"></a>

Und dies der Link, der zum Anker führen sollte:
        <p><font size="1" face="Verdana, Arial, Helvetica"><a href="#top">Seitenanfang</a>
          <a href="#top"><img src="../../bilder/systembilder/pfeil_seitenanfang.gif" width="14" height="12" border="0"></a></font></p>

leider geht das aber nicht????

Danke für die weitere Hilfe Gruss Urs

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hi @mur,

- der "top" -Anker = O.K.
- soll "Seitenanfang" od. das PfeilBild "verankert" sein od. beide ?

- ich hab das gleiche ohne TextBaustein, kuck mal in die Source  8) :

http://members.kabsi.at/erwin.billmaier/ismiscAI.htm

Danke hat sich erledigt

Gruss Mur


« spezielles PopUpum Bild herum schreiben ohne Tabelle »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!