Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Laptop friert unter Windows unregelmäßig ein, in Linux nicht?

Nur noch bis morgen: Mit Amazon Pay zahlen und 5 EUR Amazon Gutschein sichern!

Hi liebe Leute.
Ich habe folgendes Problem mit dem Laptop (eeePc 1015PN) einer Bekannten:

Unter normalen Betrieb in Windows friert irgendwann der Cursor ein und nichts geht mehr. Es wird kein minidump erstellt, es erscheint kein BSOD, die Kiste freezed einfach und reagiert auf gar nichts mehr. Erhöhte CPU oder RAM Belastung (durch PRIME 95) löst das Problem nur sporadisch aus, vom Gefühl her nicht schneller als im normalen Betrieb.

Der Eregnislog funktioniert nicht (Snapin konnte nicht geladen werden), was wohl mit dem .NET Framework zusammenhängen soll, was ich aber nicht sicher reparieren kann, da die Kiste bei der Deinstallation/Reparatur wieder abschmiert.

Im abgesicherten Modus trat das Problem bisher ein einziges Mal auf. Die Treiber sind aktuell. Die CPU Temperaturen liegen zwischen 50°C und 75°C, die Lüfter sind laut und gefühlt ständig an und das Laptop wird deutlich warm, ein Freeze tritt allerdings auch im kalten Zustand auf.
Längere Youtube Sitzungen führen regelmäßig zu einem Absturz.

Ein Dauertest mit Knoppix erzeugt keine Probleme, kein einziger Absturz. Dabei wurde sowohl CPU, als auch RAM belastet und etwa 10 GB Daten auf eine externe Platte kopiert. Ein kompletter Virusscan mit fsecure und avira wurde ebenfalls durchgeführt. Ebenso ein kompletter memtest und ein ausführlicher SMART selftest der Festplatte.

Die Kiste ging schon durch einige Hände und hat noch viel Zeug installiert, das ich durch die Abstürze nicht zuverlässig runter bekomme. Daher habe ich mich irgendwann für eine Neuinstallation entschieden. Die Auto Recovery scheint nicht zu funktionieren, es scheint die Recovery Partition nicht gefunden zu weden. Es existiert zwar eine versteckte Partition, die ist aber nur etwa 100 MB groß. Wo befindet sich die recovery Partition bei den Asus eeePCs? Kann gut sein, dass ein Vorbesitzer die gelöscht hat.

Beim booten von USB Stick mit Windows setup schmiert die Kiste leider ebenfalls beim Kopieren der Windows Daten ab (in 3/3 Versuchen an unterschiedlichen Prozentanzeigen).
Damit bin ich am Ende meines Lateins und frage mich und euch:

Wenn es ein Software Fehler ist, warum stürzt die Kiste bei der Windows Installation ab und wenn es ein Hardwarefehler ist, warum dann kein Absturz unter Linux?

Ich hoffe ihr könnt mir weiter helfen.
Vielen Dank,
Jan



Antworten zu Laptop friert unter Windows unregelmäßig ein, in Linux nicht?:

Hallo JanK!

Die Feststellung, dass Linux läuft und Windows nicht, hinkt etwas. Knoppix läuft ja vermutlich als Live-CD und nicht als Festinstallation. Hierbei wird das ganze Betriebssystem in den Arbeitsspeicher geladen. Die Festinstallation  von Windows befindet sich aber bekannter Maßen auf der Festplatte. Kann man also nur bedingt miteinander vergleichen.
Ist dem so!
Zur  exakten Festplattenbelegung: Öffne unter Knoppix das Terminal (STRG + ALT + T) und gebe bitte folgende Befehle ein:
sudo parted -l
sudo fdisk -l
(-l = kleines L) Die jeweiligen Terminalausgaben hier posten. Die 100MB Partition dürfte die Systempartition mit Bootdateien von W7 sein. Für Recovery zu klein.

Was heißt "abschmieren" genau?

Gruß

Hi Klaus,

vielen Dank für deine Antwort.

Jawohl, Knoppix ist ne live DVD und läuft aus dem RAM. Nichts desto trotz wird ja auch die Hardware benutzt und es sollte sich doch bei einem Hardwaredefekt, der Windows einfrieren lässt zumindest im syslog o.ä. was finden?

Abschmieren bedeutet wie beschrieben ein vollständiges Einfrieren des Systems. Keine Reaktion auf irgendetwas, ich muss das Gerät hart am Ausschalter ausschalten.

Das Windows Setup läuft auch vom USB Stick aus und erzeugt einen Absturz, allerdings bisher erst bei Zugriff auf die Festplatte. Aber wie gesagt, lange Kopieraktionen in Linux haben nicht zu einem Fehler geführt.

Was die Partitionen angeht, so befinden sich exakt drei Partitionen auf der Platte. Die erste ist die erste ist etwa 105 MB groß und hat ne boot flag. Die zweite ist 105 GB groß und die Windows Partition, die dritte eine Daten- und Müllpartition, 145 GB groß. Alle drei sind mit NTFS formatiert. parted und fdisk zeigen das selbe. Festplattenmodell ist ATA ST9250315AS

Wenn du drauf bestehst, füge ich die Konsolenausgabe ein, dauert aber etwas.

Schöne Grüße,
Jan

Hi!
 

Zitat
Jawohl, Knoppix ist ne live DVD und läuft aus dem RAM. Nichts desto trotz wird ja auch die Hardware benutzt

Aber die HDD eben nicht! Womit wir schon mal einen möglichen Verdächtigen hätten.
Wenn du irgendwo in der Schublade noch ne andere HDD hättest, könntest du die ja mal rein schieben und testen ob die Installation damit möglich wäre, oder alternativ eine Linux Festinstallation (vorzugsweise mit einer schmalen Distro wie z.B. Lubuntu) vornehmen und schauen ob die auch "abschmiert".

Wenn auf der Win-Platte nichts wichtiges mehr drauf ist, kannst ja von Knoppix aus mal ne neue Partitionstabelle anlegen und schauen ob's was bringt. Dazu Gparted starten, oben in der Menüleiste auf "Laufwerke" gehen und den Punkt neue Partitonstabelle wählen. Danach ist die HDD platt und der MBR bereinigt. Habe hier zwar wenig Hoffnung, aber gelegentlich hat das schon "Wunder" bewirkt. Ggf. mit Gparted gleich noch in NTFS neu formatieren.

Gruß
« Letzte Änderung: 16.01.15, 18:03:44 von Klaus P »

Doch, die HDD wurde zumindest gelesen, habe damit ja ein Backup gemacht. Habe jetzt allerdings gesehen, dass die Platte read-only gemounted wurde. Habe sie jetzt mal manuell eingehängt und schreibe 10 GB Nullen drauf. Mal gucken ob was passiert.

Die komplette Platte killen möchte ich eigentlich erst, wenn nix anderes geht.

Meine Vermutung geht allerdings auch in Richtugn HDD, aber vielleicht hat ja jemand noch andere Ideen, die nicht so offensichtlich sind :)

Schöne Grüße,
Jan

Hey Leute,

folgender Stand:

24h Linux Dauertest (Knoppix aus dem RAM) und ca 50 GB von /dev/zero auf die Platte kopierten Daten keine offensichtlichen Fehler (kein freeze, keine Infos in /var/log/messages oder dmesg). Allerdings sind die Rohwerte der (SMART) Seek Error Rate deutlich gestiegen, der normierte Wert blieb hingegen bei 81. ECC Errors oder Reallocated Sectors gabs nicht.

Eine Debian netinstall Installation lief ohne Fehler durch, das System läuft auf der ehemaligen Windows Partition.

Was nun?

Schöne Grüße,
Jan


« CD-R / CD-RWext. Festplatte kann nicht vollständig aktiviert werden »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Laptop
Veralteter Begriff für einen mobilen Computer. Siehe auch Notebook...

Unterlänge
In der Typographie lassen sich die einzelnen Buchstaben des Alphabets in ein sogenanntes Linienraster oder Liniensystem vertikal einfügen. Nun lassen sich drei versc...

Betriebssystem
Das Betriebssystem ist das Steuerungsprogramm des Computers, das als eines der ersten Programme beim Hochfahren des Rechners geladen wird. Arbeitsspeicher, Festplatten, E...