Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Win XP: winXP boot.ini probleme falsche werte / start nur mit eingelegter WinXP-CD

Hallo leute!

Ich habe jetzt schon einige zeit versucht dieses problem zu beheben. Also:

Ich habe vor einiger Zeit win XP auf win XP prof. upgedatet. DOch wärend der installation kam es zu einem Absturz. Ich hab dann trotzdem irgendwie die installtion zu ende gemacht. Folgendes Probleme:

Ich hab 2 Festplatte: eine 120GB(SCSI), die nennen wir A und eine 40GB(IDE), die nennen wir B.
Meine Konfiguration früher: C:\-PLatte mit Windows oben war die A, D:\-zusatzplatte war B.

Jetzt ist die 40GB-Platte B zur C:\-Platte geworden (somit SYSTEMplatte), jedoch befindet sich Windows auf D:\ --> A-platte.

Auf beiden ist eine Boot.ini-datei vorhanden, und wenn der PC ohne eingelegte CD startet (wieso er mit der CD startet frag ich mich auch? erkennt er den pfad nicht (scheinbar sucht er ihn auf C (B-platte)). obwohl ich versucht habe manuell die werte zuerst auf default=d:\windows zu ändern hat es nix gebracht (obwohl es wenig sinn macht).

hier erst mal die boot.ini von der c:\-platte bzw. B-platte die er auch wirklich abfragt:

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partitio n(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS=&quo t;Microsoft Windows XP Professional" /fastdetect

die sache ist eben die: ich kann eigenständig nicht rausfinden was meine D:\-platte (A) für parameter hat, ob es jetzt eben disk(1) vielleicht ist? oder rdisk(2) usw.

Übrigens irgendwelche fixboot sachen in dos hab ich probiert bringt nix. Vielleicht hat ja jemand 2 betriebssysteme auf 2 verschiedenen platten und kann hier seine boot.ini posten, nur so zum probieren.

Danke für eure aufmerksamkeit, sorry dass es etwas lang geworden ist.

WÄre echt nett, wenn ihr mir helfen könntet! Bitte! Danke im vorraus

Falls von irgendeiner Relevanz:

WinXp SP2, AMD Athlon 64 3200+, 1GB Ram, Motherbord MSI K8T Neo (VIA-Chipset), usw., Beides Festplatten sind NTFS-Format

Eigenschaften Gerätemanager

A-Platte, jetzt D:\ mit Windows ==> Ort: Bus Number 0, Target ID 2, LUN 0
Volumes: Datenträger 1, Master boot record
B-Platte, jetzt C:\ ohne Win ==> Ort: Pfad 1 (1) Volumes: Datenträger 0, Partitionstyp: ebenfalls MBR



Antworten zu Win XP: winXP boot.ini probleme falsche werte / start nur mit eingelegter WinXP-CD:

Deine IDE-Platte müsste rdisk(0) und die SCSI-Platte rdisk(1) sein. Kannst du im BIOS die Bootreihenfolge so ändern, dass zuerst von SCSI gebootet wird ? Dann müsste die Boot.ini der SCSI-Platte ziehen.
Gruß
Dieter

Hi,

Hab mich gestern gespielt mit der boot.ini und den ganzen zahlen bis der pc auch mit CD nicht mehr starten konnte. Somit hab ich einmal über die Recovery-Funtkion der CD die boot.ini neu geändert (bootcfg /rebuild). Er erkannte nur eine funktionieren Version auf D:\ was auch richtig ist. Somit hab ich diese gefixt und absichtlich anders benannt (windows driveD). Bei neustart schlägt er mir schon wieder 2 möglichkeiten vor: meine driveD version und einen typischen Windows XP Professional pfad. Naja ich hab mal driveD gewählt und winXP gestartet. dort msconfig, startpfade überprüfen und natürlich ging nur mein DriveD pfad.

Hier die neue boot.ini

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="windows ddrive"

immerhin weiß ich jetzt dass windows sich auf multi(0)disk(0)rdisk(1)partition(1) befindet. Naja das problem mit dem Start ohne CD besteht weiterhin, denn sobald ich die CD rausgib und startet findet er beim laden die systemordner nicht und schlägt mir vor diese von der Original-WinXP-CD zu installiern. ICH VERSTEHS EINFACH NICHT  >:(

Irgendwie versucht er zuerst was von der CD zu laden und dann erst den Windows-Ordner. Irgendwelche Ideen?

Nuklidz

@ Dieter

Ja die Idee wäre nciht schlecht. Aber:

Ich weiß nicht wieso das so ist aber beim hochfahren meines PC passiert folgendes:

Kopfzeile von BIOS

Primary Master ...not found
Primary Slave ... (Meine 40GB-Platte, IDE)
Secondary Master ... DVD1
Secoudary Master... DVD2

floppy kommt auch irgendwann vor k.A. wann

Dann kommt ATA RAID bootagent und VIA irgendwas, der die treiber für SCSI/RAID ladet und dann nochmal

Primary Master CHannel 0 ... (Meine 120GB-Platte, SCSI, wo windwos oben ist)


im BIOS ist zwar die Anordnung richtig, zuerst 120GB-SCSI und dann 40GB-IDE, dennoch ist es wohl hardware-technisch so eingestellt dass er die treiber für SCSI/RAID später ladet. Somit kann bleibts bei der boot.ini von C:\ bzw 40GB IDE ohen windows.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

versuch doch mal deine Konfiguration mit der Wiederhertellungskonsole zu reparieren.

Befehl: bootcfg

Mit bootcfg /? bekommst du die Parameterbeschreibung.


« Win XP: Eigene Bilder weg nach XP installation Dsl ohne festen anschluß und mobil geht das??? »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Zugriffszeit
In Milisekunden angegebene Zeit, die das Speichermedium zum Erreichen der gesuchten Daten braucht. Die Zeit ist abhängig vom technischen Verfahren des Mediums sowie ...

Reaktionszeit
In der Elektronik versteht man unter der Reaktionszeit die Zeit, die ein Flachbildschirm benötigt, um die Farbe und die Helligkeit eines Bildpunktes zu ändern. ...

Festplatte
Die Festplatte ist ein interner Datenträger im Computer. Man unterscheidet nach den Größen der Gehäuse in 2,5" (hauptsächlich für Notebooks...