Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Umfrage: 3 D Beschleunigung der Karte

Brauche Hilfe bei Installation

Hilfe
2 (100%)

Stimmen insgesamt: 2

3 D Beschleunigung der Karte

Hallo @ Al
Bin absoluter Linux-Neueinsteiger habe erst seit heute Linux Suse 9.2 auf meinem Rechner installiert und bekomme die 3D Beschleunigung nicht eingerichtet
Habe mir wie hier schon in einem Trehd beschriben die treiber von ATI für Linux runtergeladen (Danke für den Link)Aber nun bekomme ich das ganze nicht Insalliert da die Anleitung in Englisch ist und ich nicht alles Übersetzen kann und der rest sind Böhmische Dörfer für mich denn es ist alles etwas anders wie bei Windooofffff .
Für euer Hilfe wäre ich sehr Dankbar alles andere war kein problem DSL und Netzwerk hat alles super hingehauen nur das mit der Gra.....karte das schnall ich leider nicht...
Mfg euer menjon


Antworten zu 3 D Beschleunigung der Karte:

Hallo,

hoffe Du hast die Pakete von SuSE im RPM Format.

sonst gibt es diese hier:

ftp://ftp.gwdg.de/pub/linux/suse/ftp.suse.com/suse/i386/supplementary/X



Bevor Du loslegst installiere per yast
( Kontollzentrum->yast2module->Software->Software installieren oder löschen->Systemverwaltungsmodus->ROOTPASSWORT eingeben-ok )

folgende Pakete nach:

kernel-source
gcc ( alle Pakete außer colorgcc )
make
automake
autoconf
makedev
makewhat
libtool
checkinstall
m4
xorg-x11-devel

Anschließend führst Du ein Onlineupdate durch um den aktuellen Kernel zu erhalten ( Gleicher Weg wie oben, jedoch auf Onlineupdate klicken). Der Treiber ist an den Kernel gebunden. Bei jedem Update des Selben musst du die nachfolgende Prozedur wiederholen. Drum gleich mit dem aktuellen anfangen.


W I C H T I G: Besitzer von Maschinen mit Pentium 4 CPU sollten unbedingt prüfen ob der richtige Kernel instaliert ist!! Der P4 identifiziert sich gerne als Multiprozessorsystem, so dass yast den falschen Kernel installiert.

prüfen:

in einer Rootkonsole eingeben:

uname -r   ENTER

Wenn dort Kernel 2.6.x.x-smp   statt -default auftaucht ist der falsche Kernel installiert und es wird kein Schuh draus den Treiber installieren zu können. Auch funktionieren dann oft Sound und TV Karten nicht oder nicht richtig.



Frage:  Kennst Du noch den Norton Commander? Würde die Sache erheblich vereinfachen.

Je nachdem wie Du antwortest gibts den passenden Lösungsweg. Mache erst mal die obigen Schritte.

Bis später

Dr. SuSE

« Letzte Änderung: 10.03.05, 11:16:10 von Dr. SuSE »

Vielen Dank für die schnelle Antwort und Hilfe
Ja habe die Treiber in diesem Format
So habe das mal Installiert was ich gefunden habe bis auf make automake autoconf und chekinstall habe alles dursucht aber nicht gefunden onlinupdate habe ich schon gemacht....
Ja den Nortencomander kenne ich noch ist doch so ähnlich wie der Wincomander
SO bin schon ganz gespannt wie es weiter geht....
Mfg Menjon

« Letzte Änderung: 04.03.05, 20:42:57 von Menjon »

Hallo,

make und Co brauchen wir zwingend. ohne gehts nicht. Füge die Installationsquellen aus Thread 1 hinzu, dann kannst du die Dinge auf jeden Fall installieren. Zwischenzeitlich schreib ich schon mal wie es weiter geht.

WICHTIG: DIESE BESCHREIBUNG IST FÜR A T I GRAFIKKARTEN!!! Bei Nvidia gehts anders.

Hallo,

auf gehts:

Beende alle Programme auf der grafischen Oberfläche

Drücke ALT+F1

linux login:   root   ENTER

passwort: DAS ROOTPASSORT   ENTER  ( wird blind eingegeben )

init 3    ENTER   um den Xserver zu stoppen ( die grafische Umgebung)


mc  ENTER    startet den Midnight Commander ( Bedienung kennst Du ja, drum gehe ich nicht drauf ein )

Navigiere zum Verzeichnis wo du die ATI Treiber RPM's hast.

stelle den Balken drauf und drücke ENTER  Das Paket öffnet sich.

Gehe auf Update  drücke ENTER   Paket wird installiert

Navigiere nach oben drücke ENTER um das Treiberpaket zu verlassen

Wiederhole den Schritt mit dem Kernelmodul (km_fglrx...)

Drücke STRG+o  um den mc in den Hintergrund zu schieben

tippe

SuSEconfig    ENTER

Drücke STRG+o  um den mc wieder nach vorne zu holen

Navigiere ins Verzeichnis

/usr/src/linux

tippe

make  cloneconfig   ENTER

make prepare   ENTER


navigiere zu

/usr/src/kernel-modules/fglrx

tippe

KERNEL_SOURCE=/usr/src/linux make modules

Modul wird gebaut

dann

KERNEL_SOURCE=/usr/src/linux make install

depmod -a

Drücke F10  um den mc zu beenden

tippe:

sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl  ENTER

 ( 0=  ist die Zahl und nicht Buchstabe O )

Aktiviere den 3D support

mcedit /etc/X11/XF86Config  ENTER

  - füge in der Section "Module"

      Load "dri"

    hinzu


#TV-out support aktivieren

füge in der Section "Device"

      Option "NoTV" "no"
      Option "TVStandard" "PAL-D"
      Option "FSAAScale"  "6"
 
hinzu


Drücke F2 um die Änderungen zu speichern

f10 um den Editor zu beenden


tippe:

init 5   ENTER


wieder angemeldet   öffne eine xkonsole durch klick auf das Bildschirmsymbol mit der Muschel

tippe

fgl_glxgears  

nun solltest Du einen sich drehenden Würfel mit sich darin drehenden Zahnrädern sehen.

Glückwunsch, Treiber läuft mit 3 D.

Es gibt noch die Tools:

fireglcontrol und fglrxinfo

Das Tool fglrxinfo gibt Infos über den Treiber aus und fireglcontrol, nicht schwer zu erraten, ist das von Windows her gewohnte Kontrollpanel.  


Achte bei dem Ganzen unbedingt auf GROSS-undkleinschreibung! Linux unterscheidet dies im Gegensatz zu Windows.

Have a lot of fun

« Letzte Änderung: 04.03.05, 22:17:43 von Dr. SuSE »

Hi und hallo..... Doc
Vielen Dank für die gute Beschreibung werde es nachher gleich in die Tat umsetzen..
Endschuldigt das ich erst so spät Antworte musste heute den ganzen Tag Arbeiten
Werde Dich Unterichten ob alles gut verlaufen ist
Mfg. Menjon

« Letzte Änderung: 05.03.05, 18:09:10 von Menjon »

Hallo Doc

Ich finde leider nicht alle Pakete nicht die ich noch nachinstallieren soll
das wären
automake
autoconf
makedev
makewhat
checkinstall
xorg-x11 -devel
bin amverzweifeln ....
Mfg Menjon

Hallo,

wenn Du die Installationsquellen aus Thread 1 ( hier im Forum ganz oben ) hinzufügst wird yast die Pakete finden.

Nicht gleich verzweifeln...

Hi und Hallo Dr. Suse
So da bin Ich wieder und immer noch nicht schlauer....
Also unter Software habe ich gefunden kernel-source
gcc alle pakete make makedev liptool m4

was ich nicht finde ist automake autoconf makewhat checkinstall und xorg-x11-devel
Ich weis auch nicht wo ich die finden soll habe mir unter software pakete alles anzeigen lassen
Bin völlig ratloos verzeiht das ich mich erst so spät melde habe im moment so ne blööde Arbeitszeit
Mfg Menjon
Ps Bedanke mich schon mal für euere geduld und ausdauer mit mir

Hallo,

Voraussetzung ist, das Hinzufügen der Installationsquellen, siehe hier ganz oben im Forum. Dann gibt's auch keine Probleme mit den Tools. Ich hab sie drin und kann Dein Problem nicht nachvollziehen, yast spuckt auf Anfrage per Suchbegriff alle Tools wie automake und so aus, egal ob bei 9.1 oder 9.2

« Letzte Änderung: 08.03.05, 21:52:14 von Dr. SuSE »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
Ich weis auch nicht wo ich die finden soll habe mir unter software pakete alles anzeigen lassen

Auch mal bei Paketgruppen ganz unten auf "alle" gegangen. Dann kannst du auf der rechten Seite alle von A->Z finden und nachinstallieren.

Ja so habe Ich es ja gemacht aber leider nichts gefunden
Komisch oder ....
Mfg.Menjon

hi.

ich habe alle erforderlichen pakete installiert und jeden schritt zu 100% befolgt. aber leider ohne ergebnis.

beim sax2 befehl zeigt er, dass ein fehler aufgetreten ist.

ich habe eine ati mobility radeon 9700 se.

wer kann mir helfen?

gruß carpe

Hallo Doc......
Habe aml deien Tipp bevolgt und in der Konsole
uname -r eingegeben und dort erscheint nicht default
sondern 2.6 8-24.11-smp und nun welchen Kernel brauch ich den ???? Und wie soll ich vorgehen....
Mfg. Menjon.
Ach auf suche bei den softwarepacken habe ich eingegeben was mir noch fehlte findet aber nichts irgendwie ist das komisch ich versteh das alles nicht mehr habe die DVD Version von Linux mir im netz runtergeladen.

Hallo,

das Kernelproblem löst Du so:

http://www.computerhilfen.de/hilfen-6-60752-0.html

Das andere Problem dürfte daran liegen das Du a) die Installationquellen aus dem allerersten Beitrag hier im Forum nicht hinzugefügt hast, oder b ) dabei ein Fehler passiert ist oder c) Du dabei vergessen hast die lokale DVD als Installationsquelle zu deaktivieren. Dann steht dir nämlich nur der Umfang der DVD zur Verfügung und da ist nicht alles drauf.


« dsl via sat unter suse 9.0Debian: DSL-Verbindung »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Linux
Linux bezeichnet ein kostenloses Betriebssystem, das als Open Source verfügbar ist. Die erste Version entstand 1991 und wurde von dem Finnen Linus Torvalds aus dem S...

Multiprozessor Rechner
Zu dieser speziellen Kategorie der Multiprozessor Rechnern von Computern zählen jene, die nicht auf einer einzelnen CPU basieren, sondern auf zwei oder mehr Prozesso...

ADSL
Siehe DSL ...