Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

suse 10.2 kernel update nvidia treiberprobleme

Hi,
habe mal wieder den kernel upgedatet und das alte problem, dass ich nicht auf die graphische oberfläche komme.
Der neu kernel zeigt sich im Bootmenü als
XEN openSUSE 10.2.-2.6.18.9-05.
Wenn ich den alten kernel versuche zu laden gibt es die Fehlermeldung.
Beim Neuen bootet er im textmodus und ich kann beim login eingeben was ich will, es erscheint keine graphische oberfläche, obwohl er den runlevel 5 erreicht hat.
Bisher im graphischen yastmodus versucht:
- einloggen als root-> init3 -> yast Enter-> software-> Installationsquelle  wechseln -> download.nvidia.com aktiviert-> software installieren oder löschen-> da finde ich dann leider nicht die Installationsquelle! Wie komme ich da ran?
Habe dann über -> Suche-> die installierten nividia pakete nochmal aktualisiert, aber das ergebnis ist gleich null!
Was mache ich falsch?

 


Antworten zu suse 10.2 kernel update nvidia treiberprobleme:

Hallo

kannst du bitte mal folgendes ausgaben posten mir scheint als wenn du dir da den falschen Kernel gezogen hast , Hast du sicher ist nur dieser Eintrag in grub vorhanden ?

XEN openSUSE 10.2.-2.6.18.9-05
bitte folgende Ausgabe noch posten dann sehen wir weiter

rpm -qa | grep kernel
Mfg

Schmolle
« Letzte Änderung: 10.09.07, 16:47:20 von schmolle »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,
ich habe den kernel über den normalen yast online update aufgespielt.
Seltsam ist , dass beim installieren des nvidiatreibers über den textmodus von yast nicht die nvidiaseite aufgerufen wird, obwohl ich sie aktiviert habe.
hier die daten:

kernel-bigsmp-2.6.18.8-0.5
linux-kernel-headers-2.6.18.2-3
kernel-default-2.6.18.8-0.5
kernel-xenpae-2.6.18.8-0.5
kernel-source-2.6.18.8-0.5

Danke schon mal

 

Hallo

Warst wohl ein bisschen gut mit Pakete installieren so steht kernel-default im grub drin oder nicht ? poste noch mal bitte

cat /boot/grub/menu.lst
und

ls /boot
ich würde die raten den Treiber direkt von der nvidia Seite zu nehmen !

Mfg

Schmolle

« Letzte Änderung: 10.09.07, 17:22:14 von schmolle »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

würde ich gerne, bloß wie komme ich da ran?
kernel default steht bei mir nicht im boot menü.
der einzige der hoch fährt ist der schon genannte
 

Hallo

poste doch einfach die ausgaben wenn einer der kernel hochfährt ist doch gut dann kannst du die doch posten oder nicht ?

Mfg

Schmolle

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo Schmolle,

der einzige kernel der hochfährt ist der neu installierte:XEN openSUSE 10.2.-2.6.18.9-05.
Der bleibt aber im textmodus stecken.
Wie soll ich das posten?
Ich gehe z.Z. immer mit windows ins netz,fahre den rechner hoch, fahre  den rechner runter  kann also nichts kopieren, sondern müsste alles per hand abschreiben und wieder eingeben.das sind Seiten!

Mit besten grüßen
 

Ja richtig gut

dann machen wir das so boote mit dem Kernel der geht

dann

rpm -e kernel-bigsmp kernel-default
aber vorher noch die installierten nvidia Pakete löschen !

Du wirst ja keinen Rechner mit 4GB Speicher haben also brauchst du bigsmp nicht ! Danach installierst du den kernel-default wieder und startest neu und bootest den default ! Dann kannst du den anderen kernel deinstallieren (kernel-xenpae) ! Und dann such dir die passen nvidia module passend zu deinen kernel !

Mfg

Schmolle

 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,
hört sich alles so einfach an, aber:
wie installiere ich denn den default kernel?
auch über die yast funktion?
wie deinstalliere ich den xenpae
und wie suche ich mir die passenden nvidia module zusammen? irgendwie installiert der nicht von der nvidia seite sondern von der suse quelle.
ich blick da nicht mehr durch.
zudem muss ich jetzt los und kann erst wieder abends was machen.

danke erstmal 

Hallo

Das Kannst du alles mit yast machen ! Kernel Pakete deinstallieren und installieren und das gleiche für nvidia !

Mfg

Schmolle 

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

HAllo Schmolle,
ich habe jetzt erstmal alle nvidia pakete gelöscht.
und nun fährt die kiste mit dem neuen kernel problemlos hoch.
ich denke allerdings dass ich jetzt kein 3D habe, da kein treiber installiert ist.
in der liste der treiber von der nvidiaseite ist auch keiner für diesen neuen kernel angegeben. vielleicht muss ich da noch etwas warten.
ist das sinnvoll , oder sollte ich den alten kernel wieder aufspielen? wenn es den überhaupt noch gibt?
Auf der INstallationsquelle von Suse steht nämlich der neue default kernel mit der selben nummerierung wie der xenpae-kernel und für diese seriennummer gibt es bei nvidida wie gesagt keinen treiber.

MIt besten Grüßen
 

Hallo

xenpae-kernel ( http://de.opensuse.org/Xen )

Was willst du damit den brauchst du nicht kernel-default solltest du installieren und nichts anderes !

1 Also kernel-default installieren
2 neu booten mit den kernel-default
3 alle anderen Kernel löschen
4 Nvidia Pakete für den kernel-default suchen in yast und installieren und gut ist es !

Mfg

Schmolle

« Letzte Änderung: 10.09.07, 23:13:59 von schmolle »

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,
also den default-kernel habe ich installiert und als bootstandard eingerichtet.
ALs Treiber bietet die nvidia-Installationsquelle die Version
2.6.18.8_0.3-0.1 an, der kernel hat aber die nummer
2.6.18.8-05
Ich habe da meine zweifel ob das zusammenpasst.

MIt besten Grüßen

Hallo

Da hast du recht ich weiß nicht was in der nvidia-quelle drin ist ich ziehe die Install. per Hand vor so weit so gut ! Dann machen wir das folgender maßen Installiere per yast folgende Pakete nach

kernel-sources kernel-syms gcc make autoconf sharutils libtool
lade dir den Treiber von hier runter

http://www.nvidia.de/object/linux_de.html

Install. Anleitung ist hier zu finden

http://www.computerhilfen.de/hilfen-7-69927-0.html#328744

Dann sollte das klappen

Mfg

Schmolle

Poste mal deine Grafikkarte und dein System ob 32bit oder 64bit !

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,
habe ein 32bit system und eine fx5200.
Morgen gehts weiter.
Vielen Dank und gute NACHT

Dann ist der Treiber der richtige für dich

http://www.nvidia.de/object/linux_display_ia32_100.14.11_de.html

Mfg

Schmolle

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,
alles installiert, ging sogar über das ganz normale yast(ohne auf init 3 zu gehen).
letztlich waren es doch die treiber von der installationsquelle.
ich nehme an , dass die nicht mit dem xenpae-kernel zusammenpassen.
Danke nochmal


« Andere: BetriebssystemeSuse: Suse 10.2: Bildschirmschoner funktionieren nicht »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Quellcode
Ein Quellcode, auch als Quelltext bekannt, bezeichnet einen unkompilierten Programm-Code einer Software. Der Quellcode ist meist in einer der verbreiteten Programmierspra...

Unicode
Ein Unicode ist ein "Einheitsschlüssel", der als internationaler Standard gilt. Unicode ist ein digitaler Zeichensatz zur Darstellung von weitestgehend jedem Schrift...

QR-Code
Die Abkürzung QR steht für "Quick Response" und besteht aus einer quadratischen Matrix mit schwarzen und weißen Punktren. Zudem sind auch Striche zu sehen...