Computerhilfen.de Logo
Forum
Tipps
News

Suse: Überall Ton ausser bei Kdetv

Hi zusammen,
Hab n Mega Problem. Bin Linux anfänger und check eigentlich noch net so durch. Bin jetzt seit 3 tagen dran bei meinem neuen Suse 9.3 den ton für die TV-Karte zum laufen zu bringen leider ohne erfolg(In Windows klappts aber >:(). Ich kann MP3 etc. hören, sogar kann ich mit KRecord den TV ton aufnehmen und anhören, nur Kdetv bleibt still. Ich hab keine ahnung an was es liegt, hab bei den einstellung schon alles   durchprobiert, hat aber nix gebracht.
Hab ne WinTV Primo karte und ne Hercules Digifire 7.1

 Hat einer von euch vll ne ahnung an was das liegen könnte?

Danke schonmal
Gruss Benny


Antworten zu Suse: Überall Ton ausser bei Kdetv:

Hallo,
bist Du sicher ? Klicke rechts auf das Lautprechersymbol in der Taskleiste - Mixerfenster anzeigen->Caputure
Stehen die Eingänge auf Line in ? Sind die Regler hoch ( so ca. 70 % damit es keine Übersteuerung gibt ). Ist der Tonausgang der TVkarte mit dem Line in Eingang der Soundkarte verbunden ? Hast Du evtl. den Mic-Eingang erwischt ?

Ist alle notwendige Software instaliert?

v4l-tools  ( video für Linux )
xawtv ( ein anderes TV-Programm )
tv-common
tv-fonts
motv  ( Recording )
alevt ( Videotext )
kradio ( zum Radio hören )
avidemux ( vergl. mit tmpeg )

Nicht schlecht wären auch einige Codecs wie:

mpeg2dec
faac
faad2
lame
avifile
ffmpeg
divx4linux
speex
ogmtools


Prüfe mal die Möglichkeiten bevor wir in die Konfigurationsprüfung einsteigen.

Hi, also hab das alles getestet aber ohne erfolg.  Dann hab ich eben linux neu installiert, tut aber wieder nix.
Kann das daran liegen das der LINEIN und MIC eingang von der snd. card der gleiche stecker ist? Bei windows muss ich da immer umschalten je nach dem was ich nutzen will, von der verkabelung ist alles OK, unter windows funktioniert es. Komisch ist halt das nur Kdetv kein ton rausbringt, sonst kann ich alles hören. Bin grad ueimlich ratlos :(

//edit

Was mir noch einfällt, bin von der snd Card zu meinem soundsystem Über eine Optische leitung verbunden, aber das sollt ja nichts ausmachen oder?
Und bei den einstellungsmöglichkeiten bei Kdetv stehen alle einträge (Line, AUX, Maste usw.) doppelt drin was ich auch komisch finde.

Mit Krecord kann ich den TV-Ton aufnehmen und wiedergeben, alle sounds (Systemsnds, webradio, MP3..) funktioniern Perfekt

« Letzte Änderung: 15.05.05, 16:48:34 von Benny84 »

Hast den Richtigen Tuner eingestellt?

Hast den Richtigen Tuner eingestellt?

Ja, ich denke schon, ich bekomm das bild, die sender (aber in einer schlechten qualli) und den sound kann ich über Krecord aufnehmen. Bei gamix habe ich bei capture line eingestellt . Ich frage mich wie ich kdetv auf den capture channel als tonausgabe einstellen kann?

Hallo Benny,

die Einstellungen zur TV Karte werden in der Datei tv im Verzeichnis /etc/modprobe.d  gespeichert. Die Datei kannst du mit einem Editor als Root bearbeiten. Dort findest Du einen Eintrag options bttv card = mit einer Zahl dahinter, kann auch Tunertyp stehen.

Die Liste mit den möglichen Typen findest Du im Verzeichnis

/usr/src/linux/Documentation/video4linux

Kannst mal ein paar Parameter testen. Denke, es kommt der Typ card = 2   , 10 oder 80 in Frage. ( merke Dir was yast da eingetragen hat!)

Vorausgesetzt die Verbindung zum TV-Netz ist einwandfrei kann ein falscher Typ die Probleme verursachen. 'No body is perfect` und die Hardwareerkennung auch nicht. Ist halt von Menschen programmiert.

Hi Dr. Suse,
Aus der tv Datei werde ich nicht schlau,
bei mir steht da nur das drin:


alias char-major-81 videodev
options i2c-algo-bit bit_test=1
# YaST2 configured TV card
# lgGW._QJ1pyL0idD:Hauppauge WinTV
alias char-major-81-0 bttv
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 offrin


Muss ich da den Tuner manuell eintragen?
Ich weiss auch nicht genau welchen tuner ich hab,
hab gelesen das meine Haupauge Wintv Radio den BT878 chipsatz hat.

Gruss Benny

Hallo,

schau mal hier nach:

http://portal.suse.com/sdb/de/2000/08/findeisen_bttv.html

ist zwar nicht mehr taufrisch aber der Abschnitt über modprobe und rmmod passt noch.

Hoffe es verwirrt dich nicht, sondern hilft

Hi, hab da mal die ganzen Module für die Soundprozessoren geladen,hat aber kein Ergebnis gebracht. Hab jetzt wieder das MSP3400 Modul geladen. Ich bekomm ja Ton an meinem Linein, nur KDEtv nimmt den Linein nicht denk ich, aufnehmen kann ich den TV-Ton ja. Kann ich KDEtv nicht dazu bewegen den Ton vom Capture zu nehmen?

Hallo,

starte mal xawtv. Geht es damit ?  

Nein, geht leider auch nicht, habs mit Xawtv und Xawtv4 probiert, ist alles gleich, alles ohne Ton, nur das Bild ist um einiges besser als bei KdeTV. Hab im manual von Xavtv was über n bttv gelesen, ist das n Konsolenbefehl?

Hallo,

vielleicht kleine Ursache große Wirkung. Korrigiere mal den Bug gem. dieses Beitrags ( letzter Eintrag von mir):

http://www.computerhilfen.de/hilfen-6-69946-0.html

Hat leider auch nichts gebracht :(
Gibt es evtl. ein program das mir den Linein wieder geben kann?
Dann muss ich halt kdetv und noch n extra prog anmachen um TV zu schauen.
Mich wunderts halt das Ich bei Kdetv bei den audio einstellungen jeden eintrag doppelt drin hab, und da muss ich ja auf LineIn?!
Bei gamix hab ich bei Capture auch Linein drin und kann dann mit Krecord den TV-Ton aufnehmen, also kommt der ton ja auch an.

Hallo,


Das Problem mit den doppelten Einträgen lösen:

Öffne eine Konsole (führe z.B. über [Alt]+[F2] den Befehl "konsole" aus oder klicke auf den Bildschirm mit der Muschel.
Gebe in der Konsole den Befehl sux ein.
Gebe auf Nachfrage das Passwort des Administrators (root) an. Beachte dabei, das während dieser Eingabe keine optische Rückmeldung erfolgt.
Gebe nun die folgenden Befehle in der hier genannten Reihenfolge ein:

     rcalsasound stop
     rm /etc/asound.state
     rcalsasound start
     alsactl store

( In alsasound.state werden die Mixereinstellungen gespeichert)

Beende die Anmeldung als Administrator root in der Konsole indem Du exit eingibst
Geben den Befehl "kamix & " ein.
Bestätige die Meldung [KDEInit konnte "CheckHardware" nicht starten.].
Schließe die Konsole

ggf. starte den Rechner neu.

Stelle nun die gewünschten Mixereinstellungen wieder her.

Wenn Du ein Lautsprecherpaar MIT Verstärker und separatem Lautstärkeregler hast, kannst Du diese auch direkt an den Lineout-Ausgang der TV-Karte anschließen um Sound zu hören. Zum TV schauen reichts, jedoch aufzeichnen mit motv,xdtv,mythtv und wie die Tools dazu alle heißen wird tonlos bleiben solange das Kernproblem nicht gelöst ist.





Hallo Benny,

das Thema an sich hatte ich schon mal "verhackstückt".
Guckst Du hier:

http://www.computerhilfen.de/hilfen-6-58801-0.html

Vielleicht hilft Dir es bei der Fehlersuche weiter.

 

Hi,

Also das hat nicht funktioniert(Auch nicht nach neustart).
Das mit der fehlermeldung Kamix war a bissl anderes (hab dann mal mit Kmix versucht, den hats dann auch gleich gestartet).
Hier mein auszug aus der konsole:


tux@linux:~> sux
Password:
linux:/home/tux # cd
linux:~ # rcalsasound stop
Shutting down sound driver                                           done
linux:~ # rm /etc/asound.state
linux:~ # rcalsasound start
Starting sound driver:  cs46xx                                       done
linux:~ # alsactl store
linux:~ # exit
exit
tux@linux:~> kamix &
bash: kamix: command not found
[1] 8412
[1]   Exit 127                kamix
tux@linux:~> kmix &
[1] 8419
tux@linux:~>
[1]+  Done                    kmix
tux@linux:~>

Hallo,

normalerweise ist der defaultmixer kamix. Davon bin ich ausgegangen. kannst aberauch jedes andere Mixerprogramm benutzen.
Hauptsache die Funktionen sind unterstützt.

Hi nochmal, hab was gefunden, nur weiss ich nicht wie ich das realisieren soll.


Hi!

On Tuesday 01 June 2004 15:07, Terry Eck wrote:
> [...] Picture quality is very good, just no sound. How would I go about
> checking the mixer plugin configuration? Is there a config file
> somewhere?

Are you able to check the "Advanced" button in KMix? If so, check it to
enter the Advanced Settings and disable the "Line-In As Surround" feature.
The LED/button just reads "Line-In As..." but the tooltip reads "Line-In As
Surround"


Ich hab keine ahnung wie ich mein LineIn als Surround feature Deaktivieren soll, bei meinen Mixern wird nichts in der richtung angezeigt bzw. angeboten zum ändern

Hallo,

probiere es einfach aus, weisst ja nun wie Du den"Werkszustand" wieder herstellen kannst.

Hi,
Ich kann das leider nicht ausprobieren da kein Mixer diese funktion hat, liegt wahrscheinlich an meinem snd treiber.
Weist du wo die config datei von Kdetv ist, generell ne configdatei fürn snd? Vll find ich da was.

Langsam stresst mich das Problem. Vorallem da ich das Soundsignel an meinem linein anliegen habe!

Hallo,

die Konfigurationsdateien findest Du in:

/home/username/.kde/share/config

und zwar:

kdetv-plugin-alsamixer ( alsamixer und alsamixer-gui muss installiert sein )
bei mir mit diesem Inhalt:

[ALSA Mixer]
HCTL ID=hw:0
Mixer Element=Master


kdetv-plugin-simon-misc

[Displays]
Display Text=true
Display Title=true

kdetvrc

[BT878 video Video4Linux(/dev/video)]
Channel File=$HOME/.kde/share/apps/kdetv/channels.xml
Previous Channel=6
television Brightness=32768
television Colour=32768
television Contrast=32768
television Hue=32768
television Whiteness=32768

[BT878 Video4Linux(/dev/video)]
Channel File=$HOME/.kde/share/apps/kdetv/channels.xml
Previous Channel=8
television Brightness=32768
television Colour=32768
television Contrast=32768
television Hue=32768
television Whiteness=32768

[Filter Plugins]
Bilinear Deinterlacing-Dirk Ziegelmeier=false
Greedy (Low Motion) Deinterlacing-Tom Barry (kdetv port by Dirk Ziegelmeier)=false
Greedy2Frame Deinterlacing-John Adcock, Tom Barry, Steve Grimm (kdetv port by Dirk Ziegelmeier)=false
Linear Blend Deinterlacing-Dirk Ziegelmeier=true
Overscan-Dirk Ziegelmeier=true
TomsMoComp Deinterlacing-Tom Barry (kdetv port by Dirk Ziegelmeier)=false

[General]
Aspect Ratio Mode=2
Auto Mute=false
Channel Numbering Start=2
First Time=false
Fix Aspect Ratio=true
Max Keypress Interval=2000
MouseWheelUpIsChUp=false
Previous Device=Video4Linux2: BT878 video (Lifeview FlyVideo\s
SetChannelOnSelect=false
Show Only Selected Channels=true
Snapshot Format=PNG
Snapshot Path=/root/
Snapshot Quality=-1
Snapshot Resolution=4
Volume Increment=5
Volume Restore Delay=30

[MainWindow]
Height 1024=1025
Width 1280=1273

[MainWindow Docks]
Main:Geometry=1,37,400,300
Main:dock=TVScreen
Main:view=Sidebar,TVScreen
Main:visible=true
NameList=TVScreen,Sidebar,Sidebar\\,TVScreen
Sidebar,TVScreen:first_name=Sidebar
Sidebar,TVScreen:last_name=TVScreen
Sidebar,TVScreen:orientation=1
Sidebar,TVScreen:parent=yes
Sidebar,TVScreen:sepPos=20
Sidebar,TVScreen:stayButton=false
Sidebar,TVScreen:type=GROUP
Sidebar:dockBackTo=TVScreen
Sidebar:dockBackToPos=2
Sidebar:geometry=0,0,246,881
Sidebar:stayButton=false
Sidebar:tabCaption=Channel Sidebar
Sidebar:tabToolTip=
Sidebar:type=DOCK
Sidebar:visible=false
TVScreen:stayButton=false
TVScreen:tabCaption=TV Screen
TVScreen:tabToolTip=
TVScreen:type=DOCK
Version=0.0.5

[MainWindow Toolbar mainToolBar]
Index=0

[MainWindow Toolbar viewToolBar]
IconText=IconOnly
Index=1

[MainWindow Toolbar volumeToolBar]
IconText=IconOnly
Index=0

[Misc Plugins]
Channelsuite Plugin-Dirk Ziegelmeier=true
Closed Captioning Plugin-George Staikos=true
Elegant On-screen Display Plugin-Richard Moore=true
Haze On-screen Display Plugin-George Staikos=false
Teletext Plugin-Malte Starostik=true

[Mixer Plugins]
ALSA Mixer Plugin-Neil Macvicar=true
OSS Mixer Plugin-George Staikos=false

[TipOfDay]
RunOnStart=false

[VBI Plugins]
libZVBI VBI Decoder Plugin-Dirk Ziegelmeier=true

[Video Plugins]
Video4Linux Plugin-George Staikos and others=true
XVideo Plugin-George Staikos=true

[Video4Linux2: BT878 video (Lifeview FlyVideo ]
Channel File=$HOME/.kde/share/apps/kdetv/channels.xml
Previous Channel=4

[Volume]
Volume Left=18
Volume Muted=false
Volume Right=18

[Window Geometry]
Cycle Desktop View=false
Cycle FullScreen View=true
Cycle Normal View=true
Cycle TV View=true
Disable Screensaver=true
Hide Taskbar Button Fullscreen View=false
Hide Taskbar Button Normal View=false
Hide Taskbar Button TV View=false
No Sticky when fullscreen=true
Screensaver Mode=1
Stay on Top=false
Sticky=false
TopLevel Pos=2,55
TopLevel Size=400,300
View Mode=2
Window Position X=3
Window Position Y=19


die Kanalliste findest Du in:

home/username/.kde/share/apps/kdetv/channels.xml

<?xml version="1.0" encoding="UTF-8"?>
<kdetv version="2" >
  <tvregion>
    <info>
      <contributor></contributor>
      <country></country>
      <region></region>
      <type></type>
      <comment></comment>
      <lastupdate></lastupdate>
    </info>
    <channels>
      <channel enabled="true" >
        <name>RTL</name>
        <encoding>pal</encoding>
        <source>television</source>
        <number>9</number>
        <frequency>48250</frequency>
        <url></url>
        <description></description>
      </channel>
      <channel enabled="true" >
        <name>SAT1</name>
        <encoding>pal</encoding>
        <source>television</source>
        <number>12</number>
        <frequency>55250</frequency>
        <url></url>
        <description></description>

u.s.w. für die weiteren Kanäle ( Kabelnetz SH )


Hoffe die Vorlage hilft dir weiter. Hab das Tonproblem mit Deinem Kartenmodell auch schon im Windowsforum gesichtet. Auch  Windowsuser können fern sehen aber nichts hören.

Viel Erfolg




« Suse: BOotmanager deaktiviern unter knoppixSuse: Weis jemand wine wine Ausführt und konfiguriert »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!