Computerhilfen.de Logo
Forum
Tipps
News

Ubuntu: Root- Dateisystem

Hi leute,

Ich habe mir mal Ubuntu 8.04 Hardy Heron runtergeladen, dieses hat ja eine neue Funktion und zwar diese das man Ubuntu über Windows wie ein normales Programm installieren kann. So hab alles gemacht und auch meine 2te Partition installiert. Nun wollte ich Ubuntu starten da kommt folgende Fehlermeldung:

"Es wurde kein Root-Dateisystem festgelegt...Bitte beheben sie dies im Partitionsmenü"

Kann es sein das ich Ubuntu auf C: installieren sollte? Nur hab ich da Angst das Windows XP was passiert.

Könnt ihr mir weiterhelfen?

mfg Steve_06


Antworten zu Ubuntu: Root- Dateisystem:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

 

Zitat
Ich habe mir mal Ubuntu 8.04 Hardy Heron runtergeladen, dieses hat ja eine neue Funktion und zwar diese das man Ubuntu über Windows wie ein normales Programm installieren kann.

Ubuntu ist ein eigenständiges Betriebssystem und hat mit
Windows nichts gemein und basiert auf einer ganz anderen Struktur.
Um Ubuntu zu installieren benötigst du ca. 40 GB freien Festplattenspeicher.
Schaue dir bitte folgendes an:

Videovorführung über Ubuntu

Du kannst Ubuntu natürlich in VMWare Server oder Workstation installieren, doch das ist ein anderes Thema.
Schaue bitte
hier nach
was gemeint ist.

MFG susendit

Ja ich weis das Ubuntu ein eigenständiges OS ist aber in der 8.04 Version ist ein Programm eingebaut das es erlaubt das OS in Windows zu installieren hier die Info. Man kann nachher auswählen welches OS man booten will. Nur das funzt bei mirn nicht ganz.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

guckst Du hier:

http://wiki.ubuntuusers.de/GRUB?redirect=no

Have Fun

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

@Steve_06, warum schreibst du dann nicht das es um "Wubi"
geht. Kann man ja auch nicht gleich erraten.

Lese folgendes genau durch dann klappt es ohne Probleme.

Gruß susendit

Sorry, ich hab genau das gleiche Problem und krieg das nicht hin. Bin genau nach der Wubi-Installationsanleitung vorgegangen und erhalte nach dem Neustart die gleiche Fehlermeldung wie in Beitrag #1.

Auch die Suche im Netz hat mich bisher nicht weitergebracht:
Hier hatte wohl auch keiner eine Antwort und hier scheint der Fehler wohl von alleine wieder weggegangen zu sein. Ich hab es allerdings auch schon ein paar mal ohne Erfolg versucht.

Wäre froh, wenn ihr mir helfen könntet...

Gruß,
Felix

 

Zitat
Es wurde kein Root-Dateisystem festgelegt...Bitte beheben sie dies im Partitionsmenü"

Nun hier steht es doch!

 Es wurde kein Root-Dateisystem festgelegt
also

 Bitte beheben sie dies im Partitionsmenü

wie?
na am besten ein  ein Root-Dateisystem festgelegen

Wo?
 im Partitionsmenü

Und Linux, Windows, Partitionen, Grundlagenwissen anlesen!
 

Das ist ja das Problem. Man kommt gar nicht ins Partitionsmenü. Es wird nur die Fehlermeldung angezeigt. Wenn man diese mit OK bestätigt, wird sie direkt wieder angezeigt.

So wie ich das verstehe wird das Dateisystem ja bereits vorher unter Windows angelegt und dann nur noch gemountet...

Felix

 

Zitat
So wie ich das verstehe wird das Dateisystem ja bereits vorher unter Windows angelegt und dann nur noch gemountet...
Definitiv nicht!

Installiere neu und achte drauf das du ein ROOT-FS "/" festlegst!
ein noch als "/boot" mit 100MB als ext2
und eine swap mit max. 512 MB

Ääh - es handelt sich wie schon geschrieben um eine Wubi-Installation. Hast Du schon mal Ubuntu über Wubi installiert? Dabei legt man nicht wie bei einer normalen Installation das Dateisystem fest...

Danke jedenfalls für die Hilfe!

Gnarx

 

Zitat
Ääh - es handelt sich wie schon geschrieben um eine Wubi-Installation. Hast Du schon mal Ubuntu über Wubi installiert? Dabei legt man nicht wie bei einer normalen Installation das Dateisystem fest...

Habe ich!
es wird ein Container(eine große Datei) angelegt!
in diesen Container wird ein virtuelle HDD erstellt, auf dieser eine(mehrere) Partitionen erstellt und schlussendlich wird darauf ein Dateisystem erstellt!

und dann wird ein zweiter Container für swap erstellt!

und dann wird das BS in dieser Partition(en) installiert

es sei du lässt das Ubuntu tatsächlich auf die "echte" HDD zugreifen, was nicht unbedingt mein Fall wäre!
 

Genau. Die Container werden auch angelegt (während der Installation unter Windows). Einfluss auf die Erstellung des Dateisystems hat man dabei jedoch nicht, man kann dort keine Optionen eingeben. Die Größe habe ich bei der Standardeinstellung von 15GB belassen. Das scheint ja grundsätzlich auch zu funktionieren, denn Ubuntu startet beim Neustart auch von diesem Container. Aber eben nur bis zu der besagten Fehlermeldung.

Da ich vorher eigentlich keine Optionen eingeben kann, kann ich mir auch beim besten Willen nicht vorstellen, was ich dabei falsch gemacht haben könnte. Auf der anderen Seite scheint es ja nicht allzu viele Leute zu geben, die das gleiche Problem haben...

Gnarx

EDIT: Könnte das Problem möglicherweise darin liegen, dass ich die Installation nicht auf c: sondern auf d: mache?

« Letzte Änderung: 18.12.08, 11:03:00 von Gnarx »

Während der Installation von Ubuntu wird man nach der Partitionierung gefragt und in diesen Zusammenhang ist es nötig die Dateisystem die erstellt werden, Mountpoints zu zuordnen!

Einfach mal die Meldungen die während der Installation gezeigt werden lesen, bis zum Ende versteht sich!  ;)
 

Du meinst nach dem Neustart des Systems, wo die Wubi-Installationsanleitung sagt "...und Sie wählen im Windows-Bootmanager Ubuntu aus um die Installation zu vervollständigen."?

Dann liegt da der Hund begraben. Bevor dort irgendwelche weiteren Konfigurationsoptionen angezeigt werden, kommt die beschriebene Fehlermeldung, die ich leider auch nicht Quittieren kann. Kein Eingabedialog - gar nichts.

Normalerweise müsste also an dieser Stelle das Partitionsmenü angezeigt werden? Dann weiss ich nicht, was ich sonst noch probieren könnte. Kann man vielleicht die Partitionierung auch manuell auf der Kommandozeile durchführen?

Gnarx

Man versteht man an Neuinstallation nicht!

Deinstalliere dein Wubi

dann dein Windows Neustart

dann Wubi Neuinstallation

Dann während der UBUNTU-Installation

 Einfach mal die Meldungen die während der Installation gezeigt werden lesen, bis zum Ende versteht sich!


« Suse: Linux Aspire one Mail - Mails bei web.de löschenSuse: k3b bleibt hängen »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!