Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Linux / Unix: Suse startet nicht mehr

Nach installation von WindowsXP auf Festplatte 2 startet Suse-Linux auf Platte 1 nicht mehr. kommt nur noch login.

Mein Computer-System: AMD- Athlon mit 1 GB
   
Mein PC ist etwa 3-4 Jahre alt.

Letze Aenderungen bevor der Fehler auftrat:

Ich habe neue Software installiert: Windows XP auf anderer Platte


Antworten zu Linux / Unix: Suse startet nicht mehr:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo

Wenn du windows nachträglich installierst, zerschmeisst dir die Installation von Windows den Bootloader, denn musst du wieder herstellen, danach funktionierts wieder.

schaue dir diesen Artikel an

http://www.pc-forum24.de/linux-howtos/8275-grub-bootloader-wiederherstellen-opensuse.html

gruss

Hardy1979

Grub startet, war ja ne andere Platte, aber nach einer Weile bricht Startvorgang ab, und es meldet sich ne Konsole, ich soll irgendwas reparieren.

Hallo,
wäre fein, wenn Du mal die genaue Fehlermeldung posten würdest. Ich tippe auf ne versemmelte fstab. Hast Du auf der Platte, auf der Du Win installiert hast, auch ne Linux-Partition gehabt, die per fstab gemounted war? 

am besten ein

 fdisk -l

und die Ausgabe von

 less /etc/fstab

posten

Wo denn? an dieser konsole?

Ja klar, wo denn sonst?
 

komme irgendwie nicht weiter. poste euch morgen, was ihr gesagt habt. erstmal danke für die schnellen Antworten und Gute Nacht! 

Hallo, da bin ich wieder mit m. Problem.

fehlermeldung:

fsck failed for at least one filesystem (not /)
Please repair manually and reboot.

Attention Only Control-D will reboot system in this maintenance mode
shutdown or reboot will not work.

Give root password for login:

was soll ich da machen? kann keine eurer befehle eingeben.

könnt ihr mir helfen bitte ????

Hallo,
Also die Fehlermeldung deutet m.E. auf eine kaputte fstab-Datei hin. Gib erst mal Dein Root(Admi)-Passwort an der Konsole ein und dann ENTER drücken.
Dann Die Befehle eingeben, die Knut geschrieben hat und uns das Ergebnis posten.

Danke, so hats jetzt gefunzt.


less /etc/fstab

/dev/hda1    /      reiserfs    defaults     1 1
/dev/hda2    /home  reiserfs    defaults     1 2
/dev/hda3    /swap  swap        defaults     0 0
proc         /proc  proc        defaults     0 0
sysfs        /sys   sysfs       noauto       0 0
usbfs        /proc/bus/usb    usbfs   noauto             0 0
devpts       /dev/pts         devpts  mode=0620,gid=5    0 0
/dev/hdc1    /WINDOWS/C       vfat    defaults           0 0
/dev/hdc2    /opt/spiele      ext3    acl,user_xattr     1 2
/dev/hdc3    /WINDOWS/D       ntfs    defaults           0 0
/dev/hdb     /media/CDROM     subfs   noauto             0 0
 

könnt ihr da was erkennen?

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

durch deine Windowsinstallation hast du nun einen Fehler in der Konfigurationsdatei ( fstab) zur Filepartitionstabelle. Da steht drin wo das System seine Partitionen findet und was beim Systemstart damit geschehen soll. Die Datei ist nun nicht kaputt, sondern ein Eintrag in der Datei fstab verweist auf eine Partition die an der angegeben Stelle nicht mehr vorhanden ist. Das quittiert das System postwendend mit einem Fehlstart. Die Korrektur der Fehlers ist eine Sache von ein bis zwei Minuten.  

Wenn nun kommt Give Rootpassword to login, tippst du an der Stelle dein Rootpaswort ein und drückst Enter. Nun bist du im System eingeloggt. Es gilt nun den fehlerhaften Eintrag in der Datei fstab lahm zu legen. Dazu tippe nun ein:

joe /etc/fstab  ENTERTASTE

Suche nach der Zeile wo windows , ntfs oder ähnliches was auf Windows hinweist drinsteht. Diese Zeile kommentiertst Du aus. Setzt dazu am Beginn der Zeile ein Kommentarzeichen und zwar dieses #. Speichere die Änderung ab. Tastenkombination STRG+K+q und dann y
Nun bist Du wieder in der Konsole angelangt. Mit STRG+D startet das System neu und die Suse sollte nun wieder wie gewohnt starten.

Ist dir der Umgang mit der Konsole zu fremd, geht es auch anders. OpenSUSE hat ein Reparaturtool an Bord ( auf der InbstallationsDVD ), nennt sich yast Systemrepair. Wie man damit umgeht siehe hier:
http://de.opensuse.org/SDB:YaST-System-Repair

Viel Erfolg
« Letzte Änderung: 25.08.09, 23:42:40 von Dr. SuSE »

hallo
funkt. nicht, sagt joe unbekannt.

Möglicherweise ist bei Dir joe nicht installiert.
Versuch mal das:
vim /etc/fstab <ENTER>
dann <EINFG> - Taste
danach kannst Du die Datei bearbeiten. Kommentier die Zeilen mit # aus, die Dr.SUSE geschrieben hat.
dann drücke 2X die ESC - Taste, danach einen Doppelpunkt,
dann wq , dann <ENTER>.
Dann CTRL-D , sollte neustarten und wieder funktionieren.
 

Da bin ich wieder.
Mit dem vim-befehl hat funktioniert, aber das problem ist immer noch da.


« 11.0 Wie kann ich eine RAM-Disk einrichten?Linux / Unix: Temporäre Dateien entfernen von Installierten Packeten »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Festplatte
Die Festplatte ist ein interner Datenträger im Computer. Man unterscheidet nach den Größen der Gehäuse in 2,5" (hauptsächlich für Notebooks...

Athlon
Athlon ist die eingetragende Bezeichnung für einen Prozessor der Firma AMD (Advanced Micro Devices, Inc.), einem US-amerikanischen Chip-Hersteller, der den Produktna...

Software
Der Begriff Software (zu Deutsch: weiche Ware) ist ein Sammelbegriff für sämtliche Computerprogramme, die auf einem Computer ausgeführt werden können....