Computerhilfen.de Logo
Forum
Tipps
News

Suse: Parallelen Drucker über USB einbinden

Habe folgendes Problem:

Wollte über einen USB-auf-Parallel-Adapter meinen Kyocera F-1200 Paralleldrucker über USB zum Laufen bringen.

Unter Opensuse 11.0 ging das relativ einfach über /dev/usb/lp0 und den entsprechenden Treiber.
Habe jetzt OpensSuse 11.2 drauf und hier scheitere ich jämmerlich:

1. Unter Yast bringe ich das Ding gar nicht zum Laufen: Habe versucht über den Verbindungsassistenten "Direkt angeschlossenes Gerät --> USB-Port" auszuwählen, allerdings bekomme ich dann beim Verlassen der Eingabemaske die Fehlermeldung "Keine Verbindung ausgewählt"

2. Habe dann versucht, Cups über das Webinterface zu konfigurieren (http://localhost:631) und als Schnittstelle (URI) Folgendes eingegeben: "usb://dev/usb/lp0" oder "usb://dev/usb lp0". Den Druckertreiber habe ich aus der Liste ausgewählt. Ich bekomme zwar bei keiner Variante eine Fehlermeldung, aber die Testseite wird leider nicht ausgedruckt.

Was mache ich falsch?


Antworten zu Suse: Parallelen Drucker über USB einbinden:

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

schon unter http://localhost:631/printers versucht ?

Hast du auch die Installationquellen von Cups in Yast eingefügt ?

Server:
ftp5.gwdg.de

Verzeichnis auf dem Server:
pub/opensuse/repositories/Printing/openSUSE_11.2

Dann sollte es einwandfrei funktionieren.


Gruß susendit

Danke für die superschnelle Antwort.

Leider war ich etwas ungenau:

Ich habe den Drucker unter  http://localhost:631/admin/ angelegt, allerdings kann man hier kein USB auswähle. Daher habe ich dummymäßig "HP" ausgewählt und im nächste Fenster unter "Verbindung" "hp" gelöscht und stattdessen "usb://dev/usb/lp0" eingetragen.
Ist das OK?

PS: Cups habe ich nach Deinem Hinweis über das Repository upgedated, hat aber leider nichts gebracht.

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

einige USB-Paralleladapter vertragen sich nicht mit cups 1.4.x .
Stelle sicher das 1.3 installiert ist, yast ->Software installieren oder löschen - Suchbegriff cups -> Anzeigen-Paketversion und die letzte 1.3 Version aller Cupspakete auswählen (ggf. downgraden). Ghostscript macht manchmal auch Probleme wenn die installierte Version größer 8.64.xx ist. Ggf. auch wieder zurück Von Version 8.70.xxx auf 8.64.xx gehen. Das entspricht dem Versionsstand der älteren Suseversionen. Danach sollte dein Adapter wieder zur Mitarbeit zu überreden sein.

Have Fun

Danke.
Bevor ich jetzt Alles wieder downgrade, folgende Frage:

Was muss ich denn für die URI eintragen: Ist "usb://dev/usb/lp0" in Ordnung?

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hallo,

 

Zitat
Ist "usb://dev/usb/lp0" in Ordnung?
 

Gut möglich. Lässt sich aber recht leicht herausfinden. Den Adapter vom USB-Port trennen, mit einem Dateimanger das Verzeichnis /dev beleuchten. Nun Adapter wieder einstecken und schauen welches Device hinzugefügt wurde.

Have Fun

« openSUSE 11.1 (KDE 3.5): - Nach Kernel-Update kein DVB-T mehrSuse: Übertragungsrate anzeigen »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!