Computerhilfen.de Logo
Forum
Tipps
News
Frage stellen

Win98: Defragmentierung bricht ab - warum??

Hallo Leute,

mein Computer hat die Defragmentierung der Festplatte nach ca. 2,5 Stunden plötzlich abgebrochen.

Es kam eine Fehlermeldung: Laufwerk blabla konnte wegen eines Fehlers nicht defragmentiert werden. Und ich solle bitte Scan Disc durchführen.

Was der Computer offenbar nicht wußte: unmittelbar vor dem Start der Defragmentierung hatte ich ein Scan Disc durchgeführt.

Wo kann das Problem liegen? Auf Antworten freut sich

Andi47



Antworten zu Win98: Defragmentierung bricht ab - warum??:

Hast Du die Energiesparfunktion der Festplatte ausgestellt? Mal unter Bildschirmschoner - erweiterte Funktionen prüfen, ob Festplatte nach gewisser Zeit abgeschaltet werden soll.

Hallo,

vielen Dank für die Antwort!

Nee, die Energiesparfunktion war glaub ich aktiviert. Es ging auch kurzzeitig mal der Bildschirm aus - aber als ich die Maus bewegt hab, ging alles problemlos weiter und ich dachte, alles wär okay. Er hat danach auch ca. 1 Stunde problemlos weiter defragmentiert.

Darf die Energiesparfunktion nicht aktiviert sein?

Normalerweise hat er auch vor dem Defragmentieren von sich aus ein Scandisc gemacht - kann man das irgendwie einstellen, daß er das tut?

Gruß
Andi47

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
Und ich solle bitte Scan Disc durchführen...


Oder stand dort vielleicht das du scandisk im Dos Modus ausführen sollst ?
Starte den Rechner mal neu mit gedrückter F8 Taste. Dann "nur Eingabeaufforderung" auswählen und am Dos-Promt gibst ein "scandisk" (ohne "") und Eingabetaste.

Wenn fertig startet nochmals neu mit der F8 Taste in den abgesicherten Modus und startest von dort die Defragmentierung, dann kommen Fremdprogramme auch nicht Windows hierbei in die quere  ;)

Wenn du dir dann noch die defrag.exe vom Win ME in das Windows Verzeichnis kopierst, dann geht die Sache auch um ein vielfaches schneller. Habe dir mal einen Link hierfür rausgesucht:
http://www.helmrohr.de/
Dort auf Download und die defrag.zip nehmen  :D
« Letzte Änderung: 14.04.05, 17:04:27 von 98er Helfer »

Hallo Helfer,

nein, von DOS-Modus stand da nix.

Ist es denn besser, das Defragmentieren im abgesicherten Modus durchzuführen? Geht das vielleicht auch schneller, weil er das ganze Treiber-Gedöns nicht geladen hat?

Kann ich denn die von Dir empfohlene defrag.exe für WinME auch unter 98 laufen lassen, ohne daß das Probleme gibt?

Fragen über Fragen... danke für die Antworten!

Andi47

Hallo Helfer,

Kann ich denn die von Dir empfohlene defrag.exe für WinME auch unter 98 laufen lassen, ohne daß das Probleme gibt?


[/quote

Logo,weil;

Im Abgesicherten Modus laufen keine Programme und Dienste im Hintergrund mit, egal welches BS von MS

Tja, leider klappt es immer noch net.

Habe die defrag.exe installiert, ins Windowsverzeichnis kopiert, Scandisk im DOS-Modus durchgeführt und anschließend das Defragmentieren im abgesicherten Modus durchgeführt.

Merkwürdigerweise fing er nach ca. 10-15% jedesmal wieder neu an mit Fehlermeldungen wie "Laufwerksinformationen werden neu gelesen... usw."- und schließlich brach er wieder ab mit derselben Fehlermeldung: "Laufwerk konnte wegen eines Fehlers nicht defragmentiert werden - bitte führen Sie Scandisk durch". Und das wiederum durchzuführen hat er sich auch geweigert...

Ratlose Grüße
Andi47

P.S. Das Defragementierungsprogramm läuft aber tatsächlich fixer. Geht das denn auch im NICHT abgesicherten Modus?

Nachtrag:

@98erHelfer:

In der empfohlenen Datei "defrag.txt" gibt es folgenden Passus:

1. Registry öffnen und in dem Schlüssel
HKLM\software \Microsoft\Windows\CurrentVersion\Applets\Defrag\AppStartParams
den Wert für den Parameter "UseProfile" von "1" in "0" ändern. Wenn das Profil nicht verwendet wird, werden die Programme in der Reihenfolge der  vorhandenen "Anwendung.lgn"-Dateien im \Windows\Applog - Verzeichnis optimiert, unabhängig
von der Häufigkeit ihrer Verwendung.

Diesen Parameter finde ich nicht in meiner Registry an der angegebenen Stelle. Kann das die Ursache des Übels sein?

Gruß
Andi47

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

gehe mal in den ordner windows und suche den ordner applog öffne diesen und lösche den inhalt ausnamslos wieder alles schließen und neu booten,dies müßte es eigendlich sein dein problem ;)

@Peter50:

...das hat leider auch nichts gebracht  ???

Defragmentierung stürzt immer wieder am selben Punkt ab.

What now?
Gruß
Andi

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Hast du denn scandisk mal im Dos Modus laufen lassen ?

Und ME Defrag ist auch für Win98 geeignet, nur halt wesentlich schneller  :D

« Letzte Änderung: 15.04.05, 08:48:40 von 98er Helfer »
Hast du denn scandisk mal im Dos Modus laufen lassen ?

Yep.

Zitat
Und ME Defrag ist auch für Win98 geeignet, nur halt wesentlich schneller  :D

Hab ich ja auch schon ausprobiert. Ist zwar schneller, das Resultat ist aber leider dasselbe. Kann man eigentlich die Defragmentierung ebenfalls im DOS-Modus durchführen? Vielleicht funzt das ja. :-[

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button

Gibt kein defrag im Dos-Modus

Hast du den Inhalt vom Ordner applog im Windows Verzeichnis gelöscht. Eventuell unter Arbeitsplatz und Ansicht auf alle Dateien anzeigen abändern. Danach Neustart und dann nochmals im abgesicherten Modus versuchen.


Hast du den Inhalt vom Ordner applog im Windows Verzeichnis gelöscht.


Das habe ich probiert und dabei folgende seltsame Entdeckung gemacht: er lässt sich nicht löschen. Das heißt: löschen läßt er sich schon, aber beim nächsten Neustart ist er nicht mehr leer.

Der Grund: Taskmonitor lässt sich offenbar nicht de-aktivieren. Zuerst habe ich das auf eine mögliche Kollision mit TuneUp zurück geführt, mit dem man ja auch die Autostart-Gruppe verwalten kann.

Ich habe dann sowohl im TuneUp als auch in der Windows-config.sys ALLE Einträge in der Autostartgruppe durch Anklicken der jeweiligen Häkchen de-aktiviert; und dann in der config.sys zusätzlich auch noch die Start-Option angeklickt, in der die Autostart-Gruppe NICHT mitgestartet wird, oder besser gesagt: nicht mitgestartet werden sollte.

Doch das Ergebnis: beim nächsten Neustart war trotzdem alles wieder da.

Entsprechend läßt sich auch der Ordner "Applog" nicht leeren. Jedesmal beim Neustart findet sich dort wieder eine Datei namens "Applog.ind". Das wundert mich insofern, als doch angeblich der letzte Buchstabe des suffixes mit dem Laufwerksbuchstaben identisch ist, auf dem das jeweilige Programm liegt. "D" ist bei mir das Diskettenlaufwerk; das ist aber leer.

Was zum Henker ist da los???  :-\

Gruß
Andi

Hat dir diese Antwort geholfen?

Danke ButtonHilfreiche Antwort Button
Jedesmal beim Neustart findet sich dort wieder eine Datei namens "Applog.ind".
Wird bei jedem Neustart von Windows neu angelegt. Daher kannst du auch den ganzen Inhalt vom Ordner Applog ruhig löschen, da er die Indexdatei wieder neu anlegt. Stehen dort jedoch fehlerhafte Einträge oder Einträge von nicht mehr vorhanden Programmen, so kommt Defrag nicht weiter und läuft scheinbar endlos.

« Win XP: slmWin XP: Icons verschwinden »
 

Schnelle Hilfe: Hier nach ähnlichen Fragen und passenden Tipps suchen!

Fremdwörter? Erklärungen im Lexikon!
Computer
Siehe PC....

Supercomputer
Bezeichnung für sehr schnelle Computersysteme, die ein vielfaches an Leistung normaler Desktop-Computer besitzen. Die Top 500 Liste der schnellsten Supercomputer wel...

Festplatte
Die Festplatte ist ein interner Datenträger im Computer. Man unterscheidet nach den Größen der Gehäuse in 2,5" (hauptsächlich für Notebooks...